CVE-2017-10911: Infoleak

Published Jul 5, 2017
·
Updated

Last updated 29 November 2024

Other sources

The makeresponse function in drivers/block/xen-blkback/blkback.c in the Linux kernel before 4.11.8 allows guest OS users to obtain sensitive information from host OS (or other guest OS) kernel memory by leveraging the copying of uninitialized padding fields in Xen block-interface response structures, aka XSA-216.

Affected Software

3 affected componentsFixes available
Linux Linux kernel<=4.11.7
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-1
debian/qemu
1:7.2+dfsg-7+deb12u181:7.2+dfsg-7+deb12u151:10.0.13+ds-0+deb13u11:10.0.2+ds-2+deb13u11:11.1.2+ds-3

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1
  2. Upgrade

    Upgrade debian/qemu to a version that resolves this vulnerability.

    Fixed in 1:7.2+dfsg-7+deb12u18Fixed in 1:7.2+dfsg-7+deb12u15Fixed in 1:10.0.13+ds-0+deb13u1Fixed in 1:10.0.2+ds-2+deb13u1Fixed in 1:11.1.2+ds-3
  3. Upgrade

    Upgrade Linux kernel to a version that resolves this vulnerability.

    Fixed in 4.11.8Patch XSA-216

Event History

Jul 5, 2017
CVE Published
via MITRE·01:00 AM
Data Sourced
via MITRE·01:00 AM
Description

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What systems are affected by CVE-2017-10911?

CVE-2017-10911 impacts the Linux kernel versions prior to 4.11.8 as well as QEMU and Debian packages that rely on these versions.

2

What is the potential impact of CVE-2017-10911?

CVE-2017-10911 may allow guest OS users to access sensitive information from host OS or other guest OS kernel memory due to uninitialized padding fields.

3

How can I mitigate CVE-2017-10911?

To mitigate CVE-2017-10911, upgrade to Linux kernel version 4.11.8 or later, or apply available patches for affected versions.

4

What CVE ID should I monitor for updates related to this vulnerability?

Monitor CVE-2017-10911 for updates and security advisories that detail fixes and mitigations.

5

Is CVE-2017-10911 a serious vulnerability?

Yes, CVE-2017-10911 is considered a serious vulnerability due to the potential exposure of sensitive kernel memory.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203