CVE-2017-11352: Medium severity ImageMagick ImageMagick vulnerability
In ImageMagick before 7.0.5-10, a crafted RLE image can trigger a crash because of incorrect EOF handling in coders/rle.c. NOTE: this vulnerability exists because of an incomplete fix for CVE-2017-9144.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/imagemagickto a version that resolves this vulnerability.Fixed in 8:6.9.11.60+dfsg-1.3+deb11u4Fixed in 8:6.9.11.60+dfsg-1.3+deb11u5Fixed in 8:6.9.11.60+dfsg-1.6+deb12u2Fixed in 8:6.9.11.60+dfsg-1.6+deb12u1Fixed in 8:7.1.1.43+dfsg1-1Fixed in 8:7.1.1.47+dfsg1-1 - Upgrade
Upgrade
ImageMagickto a version that resolves this vulnerability.Fixed in 7.0.5-10
Event History
Frequently Asked Questions
What is the vulnerability ID for this issue?
The vulnerability ID for this issue is CVE-2017-11352.
What is the severity level of CVE-2017-11352?
The severity level of CVE-2017-11352 is medium.
Which version of ImageMagick is affected by CVE-2017-11352?
Versions up to and excluding 7.0.5-10 of ImageMagick are affected by CVE-2017-11352.
How can I fix CVE-2017-11352?
To fix CVE-2017-11352, you should update ImageMagick to version 7.0.5-10 or later.
Where can I find more information about CVE-2017-11352?
You can find more information about CVE-2017-11352 in the references section of this page.