CVE-2017-11408: Input Validation
In Wireshark 2.2.0 to 2.2.7 and 2.0.0 to 2.0.13, the AMQP dissector could crash. This was addressed in epan/dissectors/packet-amqp.c by checking for successful list dissection.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 2.6.20-0+deb10u4Fixed in 2.6.20-0+deb10u7Fixed in 3.4.10-0+deb11u1Fixed in 4.0.6-1~deb12u1Fixed in 4.0.10-1 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.8-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2017-11408?
CVE-2017-11408 is considered a medium-severity vulnerability due to the potential for crashes of the AMQP dissector in Wireshark.
How do I fix CVE-2017-11408?
To fix CVE-2017-11408, upgrade to Wireshark versions 2.2.8, 2.4.0, or later to address the issues in the AMQP dissector.
Which versions of Wireshark are affected by CVE-2017-11408?
CVE-2017-11408 affects Wireshark versions 2.2.0 to 2.2.7 and 2.0.0 to 2.0.13.
What components are vulnerable in CVE-2017-11408?
The AMQP dissector in Wireshark is the component vulnerable in CVE-2017-11408, leading to possible crashes.
Is there a workaround for CVE-2017-11408?
There is no specific workaround recommended for CVE-2017-11408; updating to a patched version is advised.