CVE-2017-11722: Medium severity GraphicsMagick Graphicsmagick vulnerability

Published Jul 28, 2017
·
Updated

The WriteOnePNGImage function in coders/png.c in GraphicsMagick 1.3.26 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted file, because the program's actual control flow was inconsistent with its indentation. This resulted in a logging statement executing outside of a loop, and consequently using an invalid array index corresponding to the loop's exit condition.

Affected Software

18 affected componentsFixes available
GraphicsMagick Graphicsmagick=1.3.26
alpine/graphicsmagick<1.3.26-r2
1.3.26-r2
alpine/graphicsmagick<1.3.26-r2
1.3.26-r2
alpine/graphicsmagick<1.3.26-r2
1.3.26-r2
alpine/graphicsmagick<1.3.26-r2
1.3.26-r2
alpine/graphicsmagick<1.3.26-r2
1.3.26-r2
alpine/graphicsmagick<1.3.26-r2
1.3.26-r2
alpine/graphicsmagick<1.3.26-r2
1.3.26-r2
alpine/graphicsmagick<1.3.26-r2
1.3.26-r2
alpine/graphicsmagick<1.3.26-r2
1.3.26-r2
alpine/graphicsmagick<1.3.26-r2
1.3.26-r2
alpine/graphicsmagick<1.3.26-r2
1.3.26-r2
alpine/graphicsmagick<1.3.26-r2
1.3.26-r2
alpine/graphicsmagick<1.3.26-r2
1.3.26-r2
alpine/graphicsmagick<1.3.26-r2
1.3.26-r2
alpine/graphicsmagick<1.3.26-r2
1.3.26-r2
alpine/graphicsmagick<1.3.26-r2
1.3.26-r2
debian/graphicsmagick
1.4+really1.3.40-4+deb12u11.4+really1.3.45+hg17696-11.4+really1.3.49-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade alpine/graphicsmagick to a version that resolves this vulnerability.

    Fixed in 1.3.26-r2
  2. Upgrade

    Upgrade debian/graphicsmagick to a version that resolves this vulnerability.

    Fixed in 1.4+really1.3.40-4+deb12u1Fixed in 1.4+really1.3.45+hg17696-1Fixed in 1.4+really1.3.49-1

Event History

Jul 28, 2017
CVE Published
via MITRE·01:00 PM
Data Sourced
via MITRE·01:00 PM
Description
Data Sourced
via NVD·01:29 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·01:29 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2017-11722?

CVE-2017-11722 has a severity that leads to denial of service due to an out-of-bounds read and application crash.

2

How do I fix CVE-2017-11722?

To fix CVE-2017-11722, upgrade to GraphicsMagick versions 1.3.27 or later.

3

Which versions of GraphicsMagick are affected by CVE-2017-11722?

Versions of GraphicsMagick prior to 1.3.27, including version 1.3.26, are affected by CVE-2017-11722.

4

Can CVE-2017-11722 be exploited remotely?

Yes, CVE-2017-11722 can be exploited remotely through crafted PNG files.

5

What impact does CVE-2017-11722 have on applications?

The impact of CVE-2017-11722 is application instability, leading to crashes when processing specific files.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203