CVE-2017-13142: Medium severity ImageMagick ImageMagick vulnerability
In ImageMagick before 6.9.9-0 and 7.x before 7.0.6-1, a crafted PNG file could trigger a crash because there was an insufficient check for short files.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/imagemagickto a version that resolves this vulnerability.Fixed in 8:6.9.11.60+dfsg-1.3+deb11u4Fixed in 8:6.9.11.60+dfsg-1.3+deb11u3Fixed in 8:6.9.11.60+dfsg-1.6+deb12u2Fixed in 8:6.9.11.60+dfsg-1.6+deb12u1Fixed in 8:7.1.1.43+dfsg1-1Fixed in 8:7.1.1.47+dfsg1-1 - Upgrade
Upgrade
ImageMagickto a version that resolves this vulnerability.Fixed in 6.9.9-0 - Upgrade
Upgrade
ImageMagickto a version that resolves this vulnerability.Fixed in 7.0.6-1
Event History
Frequently Asked Questions
What is the severity of CVE-2017-13142?
CVE-2017-13142 is classified as a moderate severity vulnerability due to its potential to cause crashes in applications processing crafted PNG files.
How do I fix CVE-2017-13142?
To fix CVE-2017-13142, upgrade ImageMagick to version 6.9.10-0 or later or version 7.0.6-1 or later.
What versions of ImageMagick are affected by CVE-2017-13142?
CVE-2017-13142 affects versions of ImageMagick before 6.9.9-0 and all 7.x versions before 7.0.6-1.
What types of files can trigger CVE-2017-13142?
CVE-2017-13142 can be triggered by processing crafted PNG files that exploit insufficient file checks.
Is CVE-2017-13142 a remote code execution vulnerability?
No, CVE-2017-13142 is not a remote code execution vulnerability; it leads to application crashes instead.