CVE-2017-13144: Input Validation
Published Jul 25, 2017
·Updated
In ImageMagick before 6.9.7-10, there is a crash (rather than a "width ...
Affected Software
2 affected componentsFixes available
ImageMagick ImageMagick<=6.9.7-9
debian/imagemagick
8:6.9.11.60+dfsg-1.6+deb12u118:6.9.11.60+dfsg-1.6+deb12u158:7.1.1.43+dfsg1-1+deb13u128:7.1.1.43+dfsg1-1+deb13u138:7.1.2.34+dfsg1-1
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/imagemagickto a version that resolves this vulnerability.Fixed in 8:6.9.11.60+dfsg-1.3+deb11u4Fixed in 8:6.9.11.60+dfsg-1.3+deb11u5Fixed in 8:6.9.11.60+dfsg-1.6+deb12u2Fixed in 8:6.9.11.60+dfsg-1.6+deb12u1Fixed in 8:7.1.1.43+dfsg1-1Fixed in 8:7.1.1.47+dfsg1-1 - Upgrade
Upgrade
ImageMagickto a version that resolves this vulnerability.Fixed in 6.9.7-10
Event History
Jul 25, 2017
Data Sourced
via Debian·10:09 PM
SeverityAffected Software
Aug 23, 2017
CVE Published
via MITRE·06:00 AM
Data Sourced
via MITRE·06:00 AM
Description
Frequently Asked Questions
1
What is the vulnerability ID for this ImageMagick vulnerability?
The vulnerability ID for this ImageMagick vulnerability is CVE-2017-13144.
2
What is the severity of CVE-2017-13144?
The severity of CVE-2017-13144 is medium (6.5).
3
What is the affected software for CVE-2017-13144?
The affected software for CVE-2017-13144 is ImageMagick before version 6.9.7-10.
4
What is the impact of CVE-2017-13144?
The impact of CVE-2017-13144 is a crash if the image dimensions are too large.
5
How can I fix CVE-2017-13144?
To fix CVE-2017-13144, update ImageMagick to version 6.9.7-10 or later.