CVE-2017-13723: Buffer Overflow
In X.Org Server (aka xserver and xorg-server) before 1.19.4, a local attacker authenticated to the X server could overflow a global buffer, causing crashes of the X server or potentially other problems by injecting large or malformed XKB related atoms and accessing them via xkbcomp.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/xorg-serverto a version that resolves this vulnerability.Fixed in 2:1.20.4-1+deb10u4Fixed in 2:1.20.4-1+deb10u9Fixed in 2:1.20.11-1+deb11u6Fixed in 2:21.1.7-3Fixed in 2:21.1.8-1 - Upgrade
Upgrade
alpine/xorg-serverto a version that resolves this vulnerability.Fixed in 1.19.5-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2017-13723?
CVE-2017-13723 has a high severity rating due to its potential to cause crashes and disruption in X server operations.
How do I fix CVE-2017-13723?
To fix CVE-2017-13723, update the xorg-server package to version 1.19.4 or later.
Who is affected by CVE-2017-13723?
CVE-2017-13723 affects systems running versions of xorg-server prior to 1.19.4, specifically on Debian GNU/Linux.
What type of attack does CVE-2017-13723 enable?
CVE-2017-13723 enables local authenticated attackers to exploit a buffer overflow vulnerability in the X server.
Is CVE-2017-13723 a remote vulnerability?
No, CVE-2017-13723 is not a remote vulnerability; it requires local authentication to the X server.