CVE-2017-13766: High severity Wireshark Wireshark vulnerability
In Wireshark 2.4.0 and 2.2.0 to 2.2.8, the Profinet I/O dissector could crash with an out-of-bounds write. This was addressed in plugins/profinet/packet-dcerpc-pn-io.c by adding string validation.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 2.6.20-0+deb10u4Fixed in 2.6.20-0+deb10u7Fixed in 3.4.10-0+deb11u1Fixed in 4.0.6-1~deb12u1Fixed in 4.0.10-1 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.4.1-r0 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.9-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2017-13766?
CVE-2017-13766 has been assigned a high severity rating due to the potential for crashing the application.
How do I fix CVE-2017-13766?
To fix CVE-2017-13766, update Wireshark to version 2.6.20 or later.
Which versions of Wireshark are affected by CVE-2017-13766?
CVE-2017-13766 affects Wireshark versions 2.0.0 to 2.4.0.
What type of vulnerability is CVE-2017-13766?
CVE-2017-13766 is an out-of-bounds write vulnerability found in the Profinet I/O dissector.
Is there a workaround for CVE-2017-13766 before applying a patch?
There is no known workaround for CVE-2017-13766; updating to a patched version is recommended.