CVE-2017-14033: Buffer Overflow

Published Sep 14, 2017
·
Updated

It was found that the decode method of the OpenSSL::ASN1 module was vulnerable to buffer underrun. An attacker could pass a specially crafted string to the application in order to crash the ruby interpreter, causing a denial of service.

Other sources

Ruby. Multiple issues in Ruby were addressed in this update.

The decode method in the OpenSSL::ASN1 module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause a denial of service (interpreter crash) via a crafted string. The openssl gem that contains this module is patched in version 2.0.0.

The decode method in the OpenSSL::ASN1 module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause a denial of service (interpreter crash) via a crafted string.

There is a buffer underrun vulnerability in OpenSSL bundled by Ruby. If a malicious string is passed to the decode method of OpenSSL::ASN1, buffer underrun may be caused and the Ruby interpreter may crash.

References:

https://bugzilla.novell.com/showbug.cgi?id=1058757 https://www.ruby-lang.org/en/news/2017/09/14/openssl-asn1-buffer-underrun-cve-2017-14033/

— Red Hat

Credit

CVE-2017-0898, CVE-2017-10784, CVE-2017-14033, CVE-2017-14064, CVE-2017-17405, CVE-2017-17742, CVE-2018-6914, CVE-2018-8777, CVE-2018-8778, CVE-2018-8779, CVE-2018-8780

Affected Software

65 affected componentsFixes available
redhat/ruby<0:2.0.0.648-33.el7_4
0:2.0.0.648-33.el7_4
redhat/rh-ruby22-ruby<0:2.2.9-19.el6
0:2.2.9-19.el6
redhat/rh-ruby23-ruby<0:2.3.6-67.el6
0:2.3.6-67.el6
redhat/rh-ruby22-ruby<0:2.2.9-19.el7
0:2.2.9-19.el7
redhat/rh-ruby23-ruby<0:2.3.6-67.el7
0:2.3.6-67.el7
rubygems/openssl<2.0.0
2.0.0
debian/ruby1.8
debian/ruby1.9.1
debian/ruby2.1
redhat/ruby<2.2.8
2.2.8
redhat/ruby<2.3.5
2.3.5
redhat/ruby<2.4.0
2.4.0
ruby-lang Ruby=2.2.0
ruby-lang Ruby=2.2.0-preview1
ruby-lang Ruby=2.2.0-preview2
ruby-lang Ruby=2.2.0-rc1
ruby-lang Ruby=2.2.1
ruby-lang Ruby=2.2.2
ruby-lang Ruby=2.2.3
ruby-lang Ruby=2.2.4
ruby-lang Ruby=2.2.5
ruby-lang Ruby=2.2.6
ruby-lang Ruby=2.2.7
ruby-lang Ruby=2.3.0
ruby-lang Ruby=2.3.0-preview1
ruby-lang Ruby=2.3.0-preview2
ruby-lang Ruby=2.3.1
ruby-lang Ruby=2.3.2
ruby-lang Ruby=2.3.3
ruby-lang Ruby=2.3.4
ruby-lang Ruby=2.4.0
ruby-lang Ruby=2.4.0-preview1
ruby-lang Ruby=2.4.0-preview2
ruby-lang Ruby=2.4.0-preview3
ruby-lang Ruby=2.4.0-rc1
ruby-lang Ruby=2.4.1
Apple macOS Mojave<10.14.1
10.14.1
Apple High Sierra
Apple Sierra
Apple macOS High Sierra<10.13.6
10.13.6
Apple El Capitan
alpine/ruby<2.4.2-r0
2.4.2-r0
alpine/ruby<2.4.2-r0
2.4.2-r0
alpine/ruby<2.4.2-r0
2.4.2-r0
alpine/ruby<2.4.2-r0
2.4.2-r0
alpine/ruby<2.4.2-r0
2.4.2-r0
alpine/ruby<2.4.2-r0
2.4.2-r0
alpine/ruby<2.4.2-r0
2.4.2-r0
alpine/ruby<2.4.2-r0
2.4.2-r0
alpine/ruby<2.4.2-r0
2.4.2-r0
alpine/ruby<2.4.2-r0
2.4.2-r0
alpine/ruby<2.4.2-r0
2.4.2-r0
alpine/ruby<2.4.2-r0
2.4.2-r0
alpine/ruby<2.4.2-r0
2.4.2-r0
alpine/ruby<2.4.2-r0
2.4.2-r0
alpine/ruby<2.4.2-r0
2.4.2-r0
alpine/ruby<2.2.8-r0
2.2.8-r0
alpine/ruby<2.3.5-r0
2.3.5-r0
alpine/ruby<2.3.5-r0
2.3.5-r0
alpine/ruby<2.4.2-r0
2.4.2-r0
alpine/ruby<2.4.2-r0
2.4.2-r0
alpine/ruby<2.4.2-r0
2.4.2-r0
alpine/ruby<2.4.2-r0
2.4.2-r0
alpine/ruby2.2<2.2.8-r0
2.2.8-r0
alpine/ruby2.2<2.2.8-r0
2.2.8-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade redhat/ruby to a version that resolves this vulnerability.

    Fixed in 0:2.0.0.648-33.el7_4
  2. Upgrade

    Upgrade redhat/rh-ruby22-ruby to a version that resolves this vulnerability.

    Fixed in 0:2.2.9-19.el6
  3. Upgrade

    Upgrade redhat/rh-ruby23-ruby to a version that resolves this vulnerability.

    Fixed in 0:2.3.6-67.el6
  4. Upgrade

    Upgrade redhat/rh-ruby22-ruby to a version that resolves this vulnerability.

    Fixed in 0:2.2.9-19.el7
  5. Upgrade

    Upgrade redhat/rh-ruby23-ruby to a version that resolves this vulnerability.

    Fixed in 0:2.3.6-67.el7
  6. Upgrade

    Upgrade rubygems/openssl to a version that resolves this vulnerability.

    Fixed in 2.0.0
  7. Upgrade

    Upgrade redhat/ruby to a version that resolves this vulnerability.

    Fixed in 2.2.8
  8. Upgrade

    Upgrade redhat/ruby to a version that resolves this vulnerability.

    Fixed in 2.3.5
  9. Upgrade

    Upgrade redhat/ruby to a version that resolves this vulnerability.

    Fixed in 2.4.0
  10. Upgrade

    Upgrade macOS Mojave to a version that resolves this vulnerability.

    Fixed in 10.14.1
  11. Upgrade

    Upgrade macOS High Sierra to a version that resolves this vulnerability.

    Fixed in 10.13.6
  12. Upgrade

    Upgrade alpine/ruby to a version that resolves this vulnerability.

    Fixed in 2.4.2-r0
  13. Upgrade

    Upgrade alpine/ruby to a version that resolves this vulnerability.

    Fixed in 2.2.8-r0
  14. Upgrade

    Upgrade alpine/ruby to a version that resolves this vulnerability.

    Fixed in 2.3.5-r0
  15. Upgrade

    Upgrade alpine/ruby2.2 to a version that resolves this vulnerability.

    Fixed in 2.2.8-r0
  16. Upgrade

    Upgrade Ruby openssl gem to a version that resolves this vulnerability.

    Fixed in 2.0.0
  17. Upgrade

    Upgrade Ruby to a version that resolves this vulnerability.

    Fixed in 2.2.8
  18. Upgrade

    Upgrade Ruby to a version that resolves this vulnerability.

    Fixed in 2.3.5

Event History

Sep 14, 2017
CVE Published
12:00 AM
Sep 16, 2017
Data Sourced
08:39 AM
SeverityAffected Software
Sep 19, 2017
CVE Published
via MITRE·05:00 PM
Data Sourced
via MITRE·05:00 PM
Description
Data Sourced
via NVD·05:29 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·05:29 PM
DescriptionSeverityAffected Software
May 14, 2022
Advisory Published
02:03 AM

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is CVE-2017-14033?

CVE-2017-14033 is a vulnerability in Ruby that allows an attacker to crash the Ruby interpreter, causing a denial of service.

2

What is the severity of CVE-2017-14033?

CVE-2017-14033 has a severity level of high.

3

How can I fix CVE-2017-14033?

To fix CVE-2017-14033, update Ruby to version 2.2.8 or higher.

4

Where can I find more information about CVE-2017-14033?

You can find more information about CVE-2017-14033 on the NIST National Vulnerability Database (NVD) at https://nvd.nist.gov/vuln/detail/CVE-2017-14033.

5

Is there a Red Hat security advisory for CVE-2017-14033?

Yes, there are Red Hat security advisories for CVE-2017-14033. You can find them at https://access.redhat.com/errata/RHSA-2018:0378 and https://access.redhat.com/errata/RHSA-2018:0583.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203