CVE-2017-14624: Null Pointer Dereference
ImageMagick 7.0.7-0 Q16 has a NULL Pointer Dereference vulnerability i ...
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/imagemagickto a version that resolves this vulnerability.Fixed in 8:6.9.11.60+dfsg-1.3+deb11u4Fixed in 8:6.9.11.60+dfsg-1.3+deb11u5Fixed in 8:6.9.11.60+dfsg-1.6+deb12u2Fixed in 8:6.9.11.60+dfsg-1.6+deb12u1Fixed in 8:7.1.1.43+dfsg1-1Fixed in 8:7.1.1.47+dfsg1-1
Event History
Frequently Asked Questions
What is CVE-2017-14624?
CVE-2017-14624 is a NULL Pointer Dereference vulnerability in ImageMagick 7.0.7-0 Q16.
How severe is CVE-2017-14624?
CVE-2017-14624 has a severity rating of 9.8 (Critical).
Which versions of ImageMagick are affected by CVE-2017-14624?
ImageMagick versions 7.0.7-0 Q16 and earlier are affected by CVE-2017-14624.
How can I fix CVE-2017-14624?
To fix CVE-2017-14624, you should update ImageMagick to versions 8:6.9.7.4+dfsg-16ubuntu2.2 or later.
Where can I find more information about CVE-2017-14624?
You can find more information about CVE-2017-14624 at the following references: [GitHub](https://github.com/ImageMagick/ImageMagick/issues/722), [SecurityFocus](http://www.securityfocus.com/bid/100940), [Ubuntu Security Notice](https://usn.ubuntu.com/3681-1/).