CVE-2017-14919: Input Validation

Published Oct 24, 2017
·
Updated

Node.js before 4.8.5, 6.x before 6.11.5, and 8.x before 8.8.0 allows remote attackers to cause a denial of service (uncaught exception and crash) by leveraging a change in the zlib module 1.2.9 making 8 an invalid value for the windowBits parameter.

Other sources

Node.js was susceptible to a remote DoS attack due to a change that came in as part of zlib v1.2.9. In zlib v1.2.9 8 became an invalid value for the windowBits parameter and Node's zlib module will crash or throw an exception (depending on the version) if you call zlib.createDeflateRaw({windowBits: 8}).

— Node.Js

Affected Software

27 affected componentsFixes available
Nodejs Node.js=4.8.2
Nodejs Node.js=4.8.3
Nodejs Node.js=4.8.4
Nodejs Node.js=6.10.2
Nodejs Node.js=6.10.3
Nodejs Node.js=6.11.0
Nodejs Node.js=6.11.1
Nodejs Node.js=6.11.2
Nodejs Node.js=6.11.3
Nodejs Node.js=6.11.4
Nodejs Node.js=8.0.0
Nodejs Node.js=8.1.0
Nodejs Node.js=8.1.1
Nodejs Node.js=8.1.2
Nodejs Node.js=8.1.3
Nodejs Node.js=8.1.4
Nodejs Node.js=8.2.0
Nodejs Node.js=8.2.1
Nodejs Node.js=8.3.0
Nodejs Node.js=8.4.0
Nodejs Node.js=8.5.0
Nodejs Node.js=8.6.0
Nodejs Node.js=8.7.0
Node.js Node.js>=4.8.2<4.8.5, >=6.10.2<6.11.5, >=8.0.0<8.8.0
4.8.56.11.58.8.0
Node.js Node.js>=4.0.0<4.8.5
4.8.5
Node.js Node.js>=6.0.0<6.11.5
6.11.5
Node.js Node.js>=8.0.0<8.8.0
8.8.0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 4.8.5Fixed in 6.11.5Fixed in 8.8.0
  2. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 8.8.0
  3. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 4.8.5
  4. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 6.11.5
  5. Upgrade

    Upgrade Node.js to a version that resolves this vulnerability.

    Fixed in 4.8.5
  6. Upgrade

    Upgrade Node.js to a version that resolves this vulnerability.

    Fixed in 6.11.5
  7. Upgrade

    Upgrade Node.js to a version that resolves this vulnerability.

    Fixed in 8.8.0

Event History

Oct 24, 2017
CVE Published
via Node.js·10:07 PM
Data Sourced
via Node.js·10:07 PM
SeverityAffected Software
Oct 30, 2017
CVE Published
via MITRE·07:00 PM
Data Sourced
via MITRE·07:00 PM
Description
Data Sourced
via NVD·07:29 PM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2017-14919?

CVE-2017-14919 has a severity rating of high due to its potential to cause a denial of service.

2

How do I fix CVE-2017-14919?

To fix CVE-2017-14919, upgrade Node.js to version 4.8.5, 6.11.5, or 8.8.0 or later.

3

Which versions of Node.js are affected by CVE-2017-14919?

CVE-2017-14919 affects Node.js versions 4.8.2 to 4.8.4, 6.x before 6.11.5, and 8.x before 8.8.0.

4

Is CVE-2017-14919 a remote vulnerability?

Yes, CVE-2017-14919 allows remote attackers to exploit the vulnerability.

5

What type of attack does CVE-2017-14919 enable?

CVE-2017-14919 enables attackers to cause a denial of service through uncaught exceptions leading to crashes.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203