CVE-2017-15032: Critical severity ImageMagick vulnerability
ImageMagick version 7.0.7-2 contains a memory leak in ReadYCBCRImage in coders/ycbcr.c.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/imagemagickto a version that resolves this vulnerability.Fixed in 8:6.9.11.60+dfsg-1.3+deb11u4Fixed in 8:6.9.11.60+dfsg-1.3+deb11u3Fixed in 8:6.9.11.60+dfsg-1.6+deb12u2Fixed in 8:6.9.11.60+dfsg-1.6+deb12u1Fixed in 8:7.1.1.43+dfsg1-1Fixed in 8:7.1.1.47+dfsg1-1
Event History
Frequently Asked Questions
What is CVE-2017-15032?
CVE-2017-15032 is a vulnerability in ImageMagick version 7.0.7-2 that contains a memory leak in ReadYCBCRImage in coders/ycbcr.c.
How severe is CVE-2017-15032?
CVE-2017-15032 is considered critical with a severity value of 9.8.
How can I fix CVE-2017-15032 on Ubuntu?
To fix CVE-2017-15032 on Ubuntu, update the imagemagick package to version 8:6.9.7.4+dfsg-16ubuntu2.2 or later.
How can I fix CVE-2017-15032 on Debian?
To fix CVE-2017-15032 on Debian, update the imagemagick package to version 8:6.9.10.23+dfsg-2.1+deb10u1 or later.
Where can I find more information about CVE-2017-15032?
For more information about CVE-2017-15032, you can refer to the GitHub commit, Ubuntu security advisory, and the Launchpad bug report mentioned in the references.