CVE-2017-15192: High severity Wireshark Wireshark vulnerability
In Wireshark 2.4.0 to 2.4.1 and 2.2.0 to 2.2.9, the BT ATT dissector could crash. This was addressed in epan/dissectors/packet-btatt.c by considering a case where not all of the BTATT packets have the same encapsulation level.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.4.2-r0 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.10-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2017-15192?
CVE-2017-15192 is considered a moderate severity vulnerability due to the potential for the BT ATT dissector to crash.
How do I fix CVE-2017-15192?
To mitigate CVE-2017-15192, upgrade to Wireshark versions 2.4.2 or later, or 2.2.10 or later.
Which versions of Wireshark are affected by CVE-2017-15192?
Wireshark versions 2.4.0 to 2.4.1 and 2.2.0 to 2.2.9 are affected by CVE-2017-15192.
What component does CVE-2017-15192 impact in Wireshark?
CVE-2017-15192 impacts the BT ATT dissector component in Wireshark.
What happens if CVE-2017-15192 is exploited?
Exploitation of CVE-2017-15192 could lead to a denial-of-service condition by crashing the application.