CVE-2017-15193: High severity Wireshark Wireshark vulnerability

Published Oct 10, 2017
·
Updated

In Wireshark 2.4.0 to 2.4.1 and 2.2.0 to 2.2.9, the MBIM dissector could crash or exhaust system memory. This was addressed in epan/dissectors/packet-mbim.c by changing the memory-allocation approach.

Affected Software

32 affected componentsFixes available
Wireshark Wireshark=2.2.0
Wireshark Wireshark=2.2.1
Wireshark Wireshark=2.2.2
Wireshark Wireshark=2.2.3
Wireshark Wireshark=2.2.4
Wireshark Wireshark=2.2.5
Wireshark Wireshark=2.2.6
Wireshark Wireshark=2.2.7
Wireshark Wireshark=2.2.8
Wireshark Wireshark=2.2.9
Wireshark Wireshark=2.4.0
Wireshark Wireshark=2.4.1
alpine/wireshark<2.4.2-r0
2.4.2-r0
alpine/wireshark<2.4.2-r0
2.4.2-r0
alpine/wireshark<2.4.2-r0
2.4.2-r0
alpine/wireshark<2.2.10-r0
2.2.10-r0
alpine/wireshark<2.2.10-r0
2.2.10-r0
alpine/wireshark<2.2.10-r0
2.2.10-r0
alpine/wireshark<2.2.10-r0
2.2.10-r0
alpine/wireshark<2.2.10-r0
2.2.10-r0
alpine/wireshark<2.2.10-r0
2.2.10-r0
alpine/wireshark<2.2.10-r0
2.2.10-r0
alpine/wireshark<2.2.10-r0
2.2.10-r0
alpine/wireshark<2.2.10-r0
2.2.10-r0
alpine/wireshark<2.2.10-r0
2.2.10-r0
alpine/wireshark<2.2.10-r0
2.2.10-r0
alpine/wireshark<2.2.10-r0
2.2.10-r0
alpine/wireshark<2.2.10-r0
2.2.10-r0
alpine/wireshark<2.2.10-r0
2.2.10-r0
alpine/wireshark<2.4.2-r0
2.4.2-r0
alpine/wireshark<2.4.2-r0
2.4.2-r0
alpine/wireshark<2.4.2-r0
2.4.2-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade alpine/wireshark to a version that resolves this vulnerability.

    Fixed in 2.4.2-r0
  2. Upgrade

    Upgrade alpine/wireshark to a version that resolves this vulnerability.

    Fixed in 2.2.10-r0

Event History

Oct 10, 2017
CVE Published
via MITRE·09:00 PM
Data Sourced
via MITRE·09:00 PM
Description
Data Sourced
via NVD·09:29 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·09:29 PM
DescriptionSeverityAffected Software
Event
09:29 PM

Frequently Asked Questions

1

What is the severity of CVE-2017-15193?

CVE-2017-15193 has a medium severity rating due to the potential for crashes or memory exhaustion.

2

How do I fix CVE-2017-15193?

To fix CVE-2017-15193, upgrade Wireshark to version 2.4.2 or later.

3

What versions of Wireshark are affected by CVE-2017-15193?

CVE-2017-15193 affects Wireshark versions 2.2.0 to 2.2.9 and 2.4.0 to 2.4.1.

4

What issue does CVE-2017-15193 address in Wireshark?

CVE-2017-15193 addresses a flaw in the MBIM dissector that could lead to crashes or excessive memory use.

5

Who is responsible for addressing CVE-2017-15193?

The Wireshark development team is responsible for addressing CVE-2017-15193 through software updates.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203