CVE-2017-15238: Use After Free

Published Oct 11, 2017
·
Updated

ReadOneJNGImage in coders/png.c in GraphicsMagick 1.3.26 has a use-after-free issue when the height or width is zero, related to ReadJNGImage.

Affected Software

18 affected componentsFixes available
GraphicsMagick Graphicsmagick=1.3.26
Debian Debian Linux=9.0
alpine/graphicsmagick<1.3.27-r0
1.3.27-r0
alpine/graphicsmagick<1.3.27-r0
1.3.27-r0
alpine/graphicsmagick<1.3.27-r0
1.3.27-r0
alpine/graphicsmagick<1.3.27-r0
1.3.27-r0
alpine/graphicsmagick<1.3.27-r0
1.3.27-r0
alpine/graphicsmagick<1.3.27-r0
1.3.27-r0
alpine/graphicsmagick<1.3.27-r0
1.3.27-r0
alpine/graphicsmagick<1.3.27-r0
1.3.27-r0
alpine/graphicsmagick<1.3.27-r0
1.3.27-r0
alpine/graphicsmagick<1.3.27-r0
1.3.27-r0
alpine/graphicsmagick<1.3.27-r0
1.3.27-r0
alpine/graphicsmagick<1.3.27-r0
1.3.27-r0
alpine/graphicsmagick<1.3.27-r0
1.3.27-r0
alpine/graphicsmagick<1.3.27-r0
1.3.27-r0
alpine/graphicsmagick<1.3.27-r0
1.3.27-r0
debian/graphicsmagick
1.4+really1.3.40-4+deb12u11.4+really1.3.45+hg17696-11.4+really1.3.49-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade alpine/graphicsmagick to a version that resolves this vulnerability.

    Fixed in 1.3.27-r0
  2. Upgrade

    Upgrade debian/graphicsmagick to a version that resolves this vulnerability.

    Fixed in 1.4+really1.3.40-4+deb12u1Fixed in 1.4+really1.3.45+hg17696-1Fixed in 1.4+really1.3.49-1

Event History

Oct 11, 2017
CVE Published
via MITRE·03:00 AM
Data Sourced
via MITRE·03:00 AM
Description
Data Sourced
via NVD·03:29 AM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·03:29 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2017-15238?

CVE-2017-15238 has a moderate severity level due to its use-after-free vulnerability in GraphicsMagick.

2

How do I fix CVE-2017-15238?

To fix CVE-2017-15238, upgrade to a patched version of GraphicsMagick, such as 1.4+really1.3.35-1~deb10u2 or higher.

3

What software is affected by CVE-2017-15238?

CVE-2017-15238 specifically affects GraphicsMagick version 1.3.26.

4

What are the potential consequences of CVE-2017-15238?

The use-after-free issue in CVE-2017-15238 may lead to application crashes or potentially allow for remote code execution.

5

Is CVE-2017-15238 present in newer versions of GraphicsMagick?

No, CVE-2017-15238 is not present in any versions of GraphicsMagick that are newer than 1.3.26.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203