CVE-2017-15268: High severity Qemu Qemu vulnerability

Published Sep 28, 2017
·
Updated

Last updated 25 August 2025

Other sources

Qemu through 2.10.0 allows remote attackers to cause a memory leak by triggering slow data-channel read operations, related to io/channel-websock.c.

— Launchpad

Quick Emulator(Qemu) built with the I/O channels websockets support is vulnerable to a memory leakage issue. It could occur while sending screen updates to a client, which is slow to read and process them further.

A privileged guest user could use this flaw to cause a DoS on the host and/or potentially crash the Qemu process instance on the host.

Upstream patch: --------------- -> https://lists.gnu.org/archive/html/qemu-devel/2017-10/msg02278.html

References: ----------- -> https://bugs.launchpad.net/bugs/1718964 -> http://www.openwall.com/lists/oss-security/2017/10/12/4

— Red Hat

Affected Software

3 affected componentsFixes available
debian/qemu<=1:2.10.0+dfsg-2, <=1:2.8+dfsg-6
Qemu Qemu<=2.10.0
debian/qemu
1:7.2+dfsg-7+deb12u181:7.2+dfsg-7+deb12u151:10.0.13+ds-0+deb13u11:10.0.2+ds-2+deb13u11:11.1.2+ds-3

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/qemu to a version that resolves this vulnerability.

    Fixed in 1:7.2+dfsg-7+deb12u18Fixed in 1:7.2+dfsg-7+deb12u15Fixed in 1:10.0.13+ds-0+deb13u1Fixed in 1:10.0.2+ds-2+deb13u1Fixed in 1:11.1.2+ds-3

Event History

Sep 28, 2017
Data Sourced
via Red Hat·05:26 PM
DescriptionSeverityAffected Software
Oct 12, 2017
CVE Published
via MITRE·03:00 PM
Data Sourced
via MITRE·03:00 PM
Description
Data Sourced
via NVD·03:29 PM
RemedyDescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2017-15268?

CVE-2017-15268 has been classified as a moderate severity vulnerability due to its potential for causing memory leaks.

2

How do I fix CVE-2017-15268?

To fix CVE-2017-15268, upgrade to a patched version of QEMU such as 1:5.2+dfsg-11+deb11u3 or newer.

3

What software is affected by CVE-2017-15268?

CVE-2017-15268 affects QEMU versions up to and including 2.10.0 that support I/O channels with websockets.

4

Why is CVE-2017-15268 a concern for remote attackers?

CVE-2017-15268 allows remote attackers to exploit slow data-channel read operations, leading to a memory leak.

5

How can I determine if my QEMU installation is vulnerable to CVE-2017-15268?

You can determine vulnerability by checking if your QEMU version is 2.10.0 or earlier and if it includes websockets support.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203