CVE-2017-15289: Medium severity Qemu Qemu vulnerability

Published Oct 12, 2017
·
Updated

Last updated 25 August 2025

Other sources

Quick emulator(Qemu) built with the Cirrus CLGD 54xx VGA Emulator support is vulnerable to an out-of-bounds write access issues. It could occur while writing to VGA memory via mode4and5 write functions.

A privileged user inside guest could use this flaw to crash the Qemu process resulting in DoS.

Upstream patch: --------------- -> https://lists.gnu.org/archive/html/qemu-devel/2017-10/msg02557.html

Reference: ---------- -> http://www.openwall.com/lists/oss-security/2017/10/12/16

— Red Hat

The mode4and5 write functions in hw/display/cirrusvga.c in Qemu allow local OS guest privileged users to cause a denial of service (out-of-bounds write access and Qemu process crash) via vectors related to dst calculation.

— Launchpad

Affected Software

3 affected componentsFixes available
debian/qemu<=1:2.1+dfsg-12, <=1:2.10.0+dfsg-2
Qemu Qemu<=2.10.2
debian/qemu
1:7.2+dfsg-7+deb12u181:7.2+dfsg-7+deb12u151:10.0.13+ds-0+deb13u11:10.0.2+ds-2+deb13u11:11.1.2+ds-3

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/qemu to a version that resolves this vulnerability.

    Fixed in 1:7.2+dfsg-7+deb12u18Fixed in 1:7.2+dfsg-7+deb12u15Fixed in 1:10.0.13+ds-0+deb13u1Fixed in 1:10.0.2+ds-2+deb13u1Fixed in 1:11.1.2+ds-3

Event History

Oct 12, 2017
Data Sourced
via Red Hat·10:52 AM
DescriptionSeverityAffected Software
Oct 16, 2017
CVE Published
via MITRE·06:00 PM
Data Sourced
via MITRE·06:00 PM
Description
Data Sourced
via NVD·06:29 PM
RemedyDescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2017-15289?

CVE-2017-15289 is classified as a high-severity vulnerability due to its potential to allow privileged users to crash the QEMU process.

2

How do I fix CVE-2017-15289?

To fix CVE-2017-15289, upgrade to QEMU versions 1:5.2+dfsg-11+deb11u3 or higher.

3

Which versions of QEMU are affected by CVE-2017-15289?

CVE-2017-15289 affects QEMU versions up to and including 2.10.2.

4

What type of issue is CVE-2017-15289?

CVE-2017-15289 is an out-of-bounds write access vulnerability related to the Cirrus CLGD 54xx VGA Emulator.

5

Who can exploit CVE-2017-15289?

A privileged user within a guest system can exploit CVE-2017-15289 to trigger a crash in the QEMU process.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203