CVE-2017-15897: Low severity Nodejs Node.js vulnerability
Node.js had a bug in versions 8.X and 9.X which caused buffers to not be initialized when the encoding for the fill value did not match the encoding specified. For example, 'Buffer.alloc(0x100, "This is not correctly encoded", "hex");' The buffer implementation was updated such that the buffer will be initialized to all zeros in these cases.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 8.9.3Fixed in 9.2.1 - Upgrade
Upgrade
alpine/nodejsto a version that resolves this vulnerability.Fixed in 8.9.3-r0 - Upgrade
Upgrade
alpine/nodejs-currentto a version that resolves this vulnerability.Fixed in 9.2.1-r0
Event History
Parent advisories
This vulnerability appears in the following advisories.
Frequently Asked Questions
What is the severity of CVE-2017-15897?
CVE-2017-15897 is considered a moderate severity vulnerability.
How do I fix CVE-2017-15897?
To fix CVE-2017-15897, upgrade Node.js to version 8.9.3 or later, or version 9.2.1 or later.
What versions of Node.js are affected by CVE-2017-15897?
CVE-2017-15897 affects Node.js versions 8.0.0 to 8.8.1, 8.9.0 to 8.9.2, and 9.0.0 to 9.2.0.
What is the impact of CVE-2017-15897?
The impact of CVE-2017-15897 is that uninitialized buffers can lead to information leaks in potentially sensitive data.
Is Node.js LTS affected by CVE-2017-15897?
Yes, certain versions of Node.js LTS are affected by CVE-2017-15897.