CVE-2017-16526: Buffer Overflow
drivers/uwb/uwbd.c in the Linux kernel before 4.13.6 allows local users to cause a denial of service (general protection fault and system crash) or possibly have unspecified other impact via a crafted USB device.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1 - Upgrade
Upgrade
Linux kernelto a version that resolves this vulnerability.Fixed in 4.13.6
Event History
Frequently Asked Questions
What is the severity of CVE-2017-16526?
CVE-2017-16526 has been identified as a denial of service vulnerability that can lead to system crashes.
How do I fix CVE-2017-16526?
To fix CVE-2017-16526, upgrade your Linux kernel to version 4.13.6 or later.
Which versions of the Linux kernel are affected by CVE-2017-16526?
CVE-2017-16526 affects Linux kernel versions before 4.13.6, including several earlier versions.
Can CVE-2017-16526 be exploited remotely?
CVE-2017-16526 requires local access for exploitation, typically through a crafted USB device.
What impact can CVE-2017-16526 have on my system?
CVE-2017-16526 may cause general protection faults and system crashes, impacting system availability.