CVE-2017-16644: Medium severity Linux Linux kernel vulnerability
Last updated 25 April 2025
Other sources
The hdpvrprobe function in drivers/media/usb/hdpvr/hdpvr-core.c in the Linux kernel through 4.13.11 allows local users to cause a denial of service (improper error handling and system crash) or possibly have unspecified other impact via a crafted USB device.
— Launchpad
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1
Event History
Frequently Asked Questions
What is the severity of CVE-2017-16644?
CVE-2017-16644 has a severity level that indicates it can lead to a denial of service and potential system crash.
How do I fix CVE-2017-16644?
To mitigate CVE-2017-16644, upgrade to a Linux kernel version higher than 4.13.11, such as 5.10.223-1 or later.
What systems are affected by CVE-2017-16644?
CVE-2017-16644 affects Linux kernel versions up to and including 4.13.11.
What type of attack does CVE-2017-16644 facilitate?
CVE-2017-16644 facilitates a local denial of service attack through improper error handling in the hdpvr_probe function.
Is CVE-2017-16644 exploitable remotely?
CVE-2017-16644 is primarily exploitable locally by users with access to a vulnerable USB device.