CVE-2017-16653: CSRF protection does not use different tokens for HTTP and HTTPS
An issue was discovered in Symfony before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and 4.0-BETA5. The current implementation of CSRF protection in Symfony (Version >=2) does not use different tokens for HTTP and HTTPS; therefore the token is subject to MITM attacks on HTTP and can then be used in an HTTPS context to do CSRF attacks.
Other sources
CVE-2017-16653: CSRF protection does not use different tokens for HTTP and HTTPS
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/symfonyto a version that resolves this vulnerability.Fixed in 3.4.22+dfsg-2+deb10u1Fixed in 3.4.22+dfsg-2+deb10u2Fixed in 4.4.19+dfsg-2+deb11u3Fixed in 5.4.23+dfsg-1Fixed in 5.4.29+dfsg-1Fixed in 5.4.30+dfsg-1 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 3.3.13 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 3.2.14 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 2.8.31 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 2.7.38 - Upgrade
Upgrade
composer/symfony/securityto a version that resolves this vulnerability.Fixed in 3.3.13 - Upgrade
Upgrade
composer/symfony/securityto a version that resolves this vulnerability.Fixed in 3.2.14 - Upgrade
Upgrade
composer/symfony/securityto a version that resolves this vulnerability.Fixed in 2.8.31 - Upgrade
Upgrade
composer/symfony/securityto a version that resolves this vulnerability.Fixed in 2.7.38 - Upgrade
Upgrade
composer/symfony/security-csrfto a version that resolves this vulnerability.Fixed in 3.3.13 - Upgrade
Upgrade
composer/symfony/security-csrfto a version that resolves this vulnerability.Fixed in 3.2.14 - Upgrade
Upgrade
composer/symfony/security-csrfto a version that resolves this vulnerability.Fixed in 2.8.31 - Upgrade
Upgrade
composer/symfony/security-csrfto a version that resolves this vulnerability.Fixed in 2.7.38 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 2.7.38 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 2.8.31 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 3.2.14 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 3.3.13 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 3.4-BETA5 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 4.0-BETA5
Event History
Frequently Asked Questions
What is the CVE ID for this vulnerability?
The CVE ID for this vulnerability is CVE-2017-16653.
What is the severity level of CVE-2017-16653?
The severity level of CVE-2017-16653 is medium, with a severity value of 5.9.
Which versions of Symfony are affected by CVE-2017-16653?
Versions before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and 4.0-BETA5 of Symfony are affected by CVE-2017-16653.
How can this vulnerability be exploited?
This vulnerability can be exploited through a MITM (Man-in-the-Middle) attack on HTTP to obtain the CSRF token and use it in HTTPS.
Where can I find more information about CVE-2017-16653?
You can find more information about CVE-2017-16653 on the Symfony website, the NIST NVD website, and the GitHub pull request.