CVE-2017-16654: Intl bundle readers breaking out of paths
An issue was discovered in Symfony before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and 4.0-BETA5. The Intl component includes various bundle readers that are used to read resource bundles from the local filesystem. The read() methods of these classes use a path and a locale to determine the language bundle to retrieve. The locale argument value is commonly retrieved from untrusted user input (like a URL parameter). An attacker can use this argument to navigate to arbitrary directories via the dot-dot-slash attack, aka Directory Traversal.
Other sources
CVE-2017-16654: Intl bundle readers breaking out of paths
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/symfonyto a version that resolves this vulnerability.Fixed in 3.4.22+dfsg-2+deb10u1Fixed in 3.4.22+dfsg-2+deb10u2Fixed in 4.4.19+dfsg-2+deb11u3Fixed in 5.4.23+dfsg-1Fixed in 5.4.29+dfsg-1Fixed in 5.4.30+dfsg-1 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 3.3.13 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 3.2.14 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 2.8.31 - Upgrade
Upgrade
composer/symfony/symfonyto a version that resolves this vulnerability.Fixed in 2.7.38 - Upgrade
Upgrade
composer/symfony/intlto a version that resolves this vulnerability.Fixed in 3.3.13 - Upgrade
Upgrade
composer/symfony/intlto a version that resolves this vulnerability.Fixed in 3.2.14 - Upgrade
Upgrade
composer/symfony/intlto a version that resolves this vulnerability.Fixed in 2.8.31 - Upgrade
Upgrade
composer/symfony/intlto a version that resolves this vulnerability.Fixed in 2.7.38
Event History
Frequently Asked Questions
What is CVE-2017-16654?
CVE-2017-16654 is a vulnerability in the Symfony framework that allows potential path traversal attacks.
What is the severity level of CVE-2017-16654?
The severity level of CVE-2017-16654 is high with a CVSS score of 7.5.
Which versions of Symfony are affected by CVE-2017-16654?
Versions before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and 4.0-BETA5 of Symfony are affected.
How can I fix CVE-2017-16654?
To fix CVE-2017-16654, update your Symfony framework to version 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, or 4.0-BETA5.
Where can I find more information about CVE-2017-16654?
You can find more information about CVE-2017-16654 on the National Vulnerability Database (NVD) website and the GitHub pull request.