CVE-2017-16914: Null Pointer Dereference

Published Jan 31, 2018
·
Updated

Last updated 29 November 2024

Other sources

The "stubsendretsubmit()" function (drivers/usb/usbip/stubtx.c) in the Linux Kernel before version 4.14.8, 4.9.71, 4.1.49, and 4.4.107 allows attackers to cause a denial of service (NULL pointer dereference) via a specially crafted USB over IP packet.

Affected Software

5 affected componentsFixes available
Linux Linux kernel>=4.1.0<4.1.49
Linux Linux kernel>=4.4.0<4.4.107
Linux Linux kernel>=4.9.0<4.9.71
Linux Linux kernel>=4.14.0<4.14.8
debian/linux
6.1.176-16.1.190-16.12.107-16.12.113-17.2.12-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1
  2. Upgrade

    Upgrade Linux Kernel to a version that resolves this vulnerability.

    Fixed in 4.14.8
  3. Upgrade

    Upgrade Linux Kernel to a version that resolves this vulnerability.

    Fixed in 4.9.71
  4. Upgrade

    Upgrade Linux Kernel to a version that resolves this vulnerability.

    Fixed in 4.1.49
  5. Upgrade

    Upgrade Linux Kernel to a version that resolves this vulnerability.

    Fixed in 4.4.107

Event History

Jan 31, 2018
CVE Published
via MITRE·10:00 PM
Data Sourced
via MITRE·10:00 PM
DescriptionWeakness

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is CVE-2017-16914?

CVE-2017-16914 is a vulnerability in the Linux Kernel that allows attackers to cause a denial of service (NULL pointer dereference) via a specially crafted USB over IP packet.

2

How does CVE-2017-16914 affect the Linux Kernel?

CVE-2017-16914 affects the 'stub_send_ret_submit()' function in the Linux Kernel before version 4.14.8, 4.9.71, 4.1.49, and 4.4.107.

3

What is the severity of CVE-2017-16914?

CVE-2017-16914 has a severity rating of high.

4

How can I fix CVE-2017-16914?

To fix CVE-2017-16914, update your Linux Kernel to version 4.14.8, 4.9.71, 4.1.49, or 4.4.107.

5

Where can I find more information about CVE-2017-16914?

You can find more information about CVE-2017-16914 in the following references: [Reference 1](https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.1.49), [Reference 2](https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.14.8), [Reference 3](https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.4.107).

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203