CVE-2017-17083: High severity Wireshark Wireshark vulnerability
In Wireshark 2.4.0 to 2.4.2 and 2.2.0 to 2.2.10, the NetBIOS dissector could crash. This was addressed in epan/dissectors/packet-netbios.c by ensuring that write operations are bounded by the beginning of a buffer.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 2.6.20-0+deb10u4Fixed in 2.6.20-0+deb10u7Fixed in 3.4.10-0+deb11u1Fixed in 4.0.6-1~deb12u1Fixed in 4.0.10-1 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.4.3-r0 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.11-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2017-17083?
CVE-2017-17083 is considered a medium severity vulnerability that can cause crashes in the Wireshark application.
How do I fix CVE-2017-17083?
To fix CVE-2017-17083, update Wireshark to version 2.4.3 or later, or any of the patched versions listed in the advisory.
Which versions of Wireshark are affected by CVE-2017-17083?
Versions of Wireshark from 2.4.0 to 2.4.2 and 2.2.0 to 2.2.10 are affected by CVE-2017-17083.
What component of Wireshark is impacted by CVE-2017-17083?
The NetBIOS dissector component of Wireshark is impacted by CVE-2017-17083.
Is it safe to use Wireshark with CVE-2017-17083 present?
Using an affected version of Wireshark can lead to application crashes, making it unsafe to use until remediated.