CVE-2017-17085: High severity Wireshark Wireshark vulnerability
In Wireshark 2.4.0 to 2.4.2 and 2.2.0 to 2.2.10, the CIP Safety dissector could crash. This was addressed in epan/dissectors/packet-cipsafety.c by validating the packet length.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/wiresharkto a version that resolves this vulnerability.Fixed in 2.6.20-0+deb10u4Fixed in 2.6.20-0+deb10u7Fixed in 3.4.10-0+deb11u1Fixed in 4.0.6-1~deb12u1Fixed in 4.0.10-1 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.4.3-r0 - Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.11-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2017-17085?
CVE-2017-17085 has been classified as a medium severity vulnerability.
How do I fix CVE-2017-17085?
To fix CVE-2017-17085, upgrade Wireshark to a version later than 2.4.2 or apply necessary patches provided in the latest updates.
Which versions of Wireshark are affected by CVE-2017-17085?
CVE-2017-17085 affects Wireshark versions 2.4.0 to 2.4.2 and 2.2.0 to 2.2.10.
What does CVE-2017-17085 affect in Wireshark?
CVE-2017-17085 affects the CIP Safety dissector, which could cause a crash when processing packets.
Can CVE-2017-17085 lead to data exposure?
CVE-2017-17085 itself does not lead to data exposure but could disrupt network analysis by crashing the Wireshark application.