CVE-2017-17381: Divide by Zero

Published Dec 5, 2017
·
Updated

Last updated 25 August 2025

Other sources

The Virtio Vring implementation in QEMU allows local OS guest users to cause a denial of service (divide-by-zero error and QEMU process crash) by unsetting vring alignment while updating Virtio rings.

— Launchpad

Virtio Vring implementation in Quick Emulator(QEMU) is vulnerable to an arithmetic exception issue. It could occur if a guest was to unset vring alignment while updating Virtio rings.

A guest user/process could use this flaw to crash Qemu process resulting in DoS.

Upstream patch: --------------- -> https://lists.gnu.org/archive/html/qemu-devel/2017-12/msg00166.html

Affected Software

7 affected componentsFixes available
Qemu Qemu<=2.10.2
Qemu Qemu=2.11.0-rc0
Qemu Qemu=2.11.0-rc1
Qemu Qemu=2.11.0-rc2
Qemu Qemu=2.11.0-rc3
Debian Debian Linux=9.0
debian/qemu
1:7.2+dfsg-7+deb12u181:7.2+dfsg-7+deb12u151:10.0.13+ds-0+deb13u11:10.0.2+ds-2+deb13u11:11.1.2+ds-3

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/qemu to a version that resolves this vulnerability.

    Fixed in 1:7.2+dfsg-7+deb12u18Fixed in 1:7.2+dfsg-7+deb12u15Fixed in 1:10.0.13+ds-0+deb13u1Fixed in 1:10.0.2+ds-2+deb13u1Fixed in 1:11.1.2+ds-3

Event History

Dec 5, 2017
Data Sourced
07:18 AM
DescriptionSeverityAffected Software
Dec 6, 2017
CVE Published
via MITRE·04:00 PM
Data Sourced
via MITRE·04:00 PM
Description
Dec 7, 2017
Data Sourced
via NVD·02:29 AM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2017-17381?

CVE-2017-17381 has a severity rating that may lead to a denial of service by crashing the QEMU process.

2

How do I fix CVE-2017-17381?

To fix CVE-2017-17381, upgrade to a version of QEMU that is patched against this vulnerability.

3

What is the impact of CVE-2017-17381 on users?

The impact of CVE-2017-17381 allows local OS guest users to crash the QEMU process, leading to a denial of service.

4

Which software versions are affected by CVE-2017-17381?

Affected software versions include QEMU versions prior to 2.10.3 and specific Debian packages as noted.

5

Is CVE-2017-17381 exploitable remotely?

CVE-2017-17381 is not exploitable remotely as it requires local OS guest user access to trigger the vulnerability.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203