CVE-2017-17503: High severity GraphicsMagick Graphicsmagick vulnerability
Last updated 25 August 2025
Other sources
ReadGRAYImage in coders/gray.c in GraphicsMagick 1.3.26 has a magick/import.c ImportGrayQuantumType heap-based buffer over-read via a crafted file.
— Launchpad
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/graphicsmagickto a version that resolves this vulnerability.Fixed in 1.3.27-r0 - Upgrade
Upgrade
debian/graphicsmagickto a version that resolves this vulnerability.Fixed in 1.4+really1.3.40-4+deb12u1Fixed in 1.4+really1.3.45+hg17696-1Fixed in 1.4+really1.3.49-1
Event History
Frequently Asked Questions
What is CVE-2017-17503?
CVE-2017-17503 is a vulnerability in GraphicsMagick 1.3.26 that allows for a heap-based buffer over-read.
How severe is CVE-2017-17503?
CVE-2017-17503 has a severity score of 8.8, which is considered high.
Which versions of GraphicsMagick are affected by CVE-2017-17503?
Versions 1.3.18-1ubuntu3.1+ to 1.3.27-1 of GraphicsMagick are affected by CVE-2017-17503.
How can I fix CVE-2017-17503?
To fix CVE-2017-17503, update GraphicsMagick to version 1.3.28 or later.
Where can I find more information about CVE-2017-17503?
You can find more information about CVE-2017-17503 at the following references: [link1], [link2], [link3].