CVE-2017-17504: Medium severity ImageMagick ImageMagick vulnerability
ImageMagick before 7.0.7-12 has a coders/png.c Magickpngreadrawpro ...
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/imagemagickto a version that resolves this vulnerability.Fixed in 8:6.9.9.34+dfsg-1Fixed in 8:6.8.9.9-5+deb8u12 - Upgrade
Upgrade
debian/imagemagickto a version that resolves this vulnerability.Fixed in 8:6.9.11.60+dfsg-1.6+deb12u11Fixed in 8:6.9.11.60+dfsg-1.6+deb12u15Fixed in 8:7.1.1.43+dfsg1-1+deb13u12Fixed in 8:7.1.1.43+dfsg1-1+deb13u13Fixed in 8:7.1.2.34+dfsg1-1 - Upgrade
Upgrade
ImageMagickto a version that resolves this vulnerability.Fixed in 7.0.7-12
Event History
Frequently Asked Questions
What is CVE-2017-17504?
CVE-2017-17504 is a vulnerability in ImageMagick that allows a heap-based buffer over-read via a crafted file in the PNG coders/png.c component.
What is the severity of CVE-2017-17504?
The severity of CVE-2017-17504 is medium, with a severity value of 6.5.
Which versions of ImageMagick are affected by CVE-2017-17504?
ImageMagick versions before 7.0.7-12 are affected by CVE-2017-17504.
How can I fix CVE-2017-17504?
To fix CVE-2017-17504, update ImageMagick to version 7.0.7-12 or later.
Where can I find more information about CVE-2017-17504?
You can find more information about CVE-2017-17504 at the following references: [1](https://github.com/ImageMagick/ImageMagick/issues/872), [2](https://www.debian.org/security/2017/dsa-4074), [3](https://lists.debian.org/debian-lts-announce/2018/01/msg00000.html).