CVE-2017-17806: Buffer Overflow
The HMAC implementation (crypto/hmac.c) in the Linux kernel before 4.14.8 does not validate that the underlying cryptographic hash algorithm is unkeyed, allowing a local attacker able to use the AFALG-based hash interface (CONFIGCRYPTOUSERAPIHASH) and the SHA-3 hash algorithm (CONFIGCRYPTOSHA3) to cause a kernel stack buffer overflow by executing a crafted sequence of system calls that encounter a missing SHA-3 initialization.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
redhat/kernelto a version that resolves this vulnerability.Fixed in 4.14.8 - Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1 - Upgrade
Upgrade
Linux kernelto a version that resolves this vulnerability.Fixed in 4.14.8
Event History
Frequently Asked Questions
What is the severity of CVE-2017-17806?
CVE-2017-17806 is a high-severity vulnerability due to improper validation in the HMAC implementation of the Linux kernel.
How do I fix CVE-2017-17806?
To fix CVE-2017-17806, upgrade to Linux kernel version 4.14.8 or later.
Which versions of Linux are affected by CVE-2017-17806?
CVE-2017-17806 affects Linux kernel versions prior to 4.14.8, including multiple versions within the range of 3.2 to 4.14.7.
Can CVE-2017-17806 be exploited remotely?
No, CVE-2017-17806 requires local access for exploitation due to its nature of attacking the HMAC implementation.
What systems should I prioritize for CVE-2017-17806 patching?
Systems running Linux kernels prior to version 4.14.8, especially those in sensitive environments, should be prioritized for patching against CVE-2017-17806.