CVE-2017-17864: Infoleak
kernel/bpf/verifier.c in the Linux kernel through 4.14.8 mishandles statesequal comparisons between the pointer data type and the UNKNOWNVALUE data type, which allows local users to obtain potentially sensitive address information, aka a "pointer leak."
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1
Event History
Frequently Asked Questions
What is CVE-2017-17864?
CVE-2017-17864 is a vulnerability in the Linux kernel that mishandles states_equal comparisons and allows local users to obtain potentially sensitive address information, also known as a "pointer leak".
What is the severity of CVE-2017-17864?
The severity of CVE-2017-17864 is moderate.
How does CVE-2017-17864 affect Linux?
CVE-2017-17864 affects the Linux kernel through version 4.14.8.
How can I fix CVE-2017-17864?
To fix CVE-2017-17864, update your Linux kernel to version 4.15 or later.
Where can I find more information about CVE-2017-17864?
You can find more information about CVE-2017-17864 on the Debian website.