CVE-2017-18017: Use After Free
The tcpmssmanglepacket function in net/netfilter/xtTCPMSS.c in the Linux kernel before 4.11, and 4.9.x before 4.9.36, allows remote attackers to cause a denial of service (use-after-free and memory corruption) or possibly have unspecified other impact by leveraging the presence of xtTCPMSS in an iptables action.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1 - Upgrade
Upgrade
Linux kernelto a version that resolves this vulnerability.Fixed in 4.11
Event History
Frequently Asked Questions
What is the vulnerability ID?
The vulnerability ID is CVE-2017-18017.
What is the severity level of CVE-2017-18017?
The severity level of CVE-2017-18017 is medium.
What is the affected software?
The affected software includes Linux kernel versions before 4.11 and 4.9.x before 4.9.36.
What is the impact of CVE-2017-18017?
The impact of CVE-2017-18017 includes denial of service (use-after-free and memory corruption) or possibly other unspecified impacts.
Are there any remediation steps available?
Yes, updating the Linux kernel to version 4.11 or higher can address the vulnerability.