CVE-2017-18193: Buffer Overflow
fs/f2fs/extentcache.c in the Linux kernel before 4.13 mishandles extent trees, which allows local users to cause a denial of service (BUG) via an application with multiple threads.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1 - Upgrade
Upgrade
Linux kernelto a version that resolves this vulnerability.Fixed in 4.13
Event History
Frequently Asked Questions
What is CVE-2017-18193?
CVE-2017-18193 is a vulnerability in the Linux kernel that mishandles extent trees, allowing local users to cause a denial of service.
How does CVE-2017-18193 affect the Linux kernel?
CVE-2017-18193 affects the Linux kernel before version 4.13.
What is the severity of CVE-2017-18193?
The severity of CVE-2017-18193 is medium.
How can I fix CVE-2017-18193?
To fix CVE-2017-18193, you need to update your Linux kernel to version 4.13 or later.
Where can I find more information about CVE-2017-18193?
You can find more information about CVE-2017-18193 at the following references: [1], [2], [3].