CVE-2017-18257: Integer Overflow
Last updated 4 July 2026
Other sources
The getdatablock function in fs/f2fs/data.c in the Linux kernel before 4.11 allows local users to cause a denial of service (integer overflow and loop) via crafted use of the open and fallocate system calls with an FSIOCFIEMAP ioctl.
— Launchpad
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/linuxto a version that resolves this vulnerability.Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.113-1Fixed in 7.2.12-1
Event History
Frequently Asked Questions
What is the vulnerability ID for this issue?
The vulnerability ID for this issue is CVE-2017-18257.
What is the severity of CVE-2017-18257?
The severity of CVE-2017-18257 is not specified in the provided information.
How does CVE-2017-18257 affect Linux kernel before version 4.11?
CVE-2017-18257 allows local users to cause a denial of service (integer overflow and loop) via crafted use of the open and fallocate system calls with an FS_IOC_FIEMAP ioctl.
How can I fix the vulnerability CVE-2017-18257?
To fix CVE-2017-18257, update your Linux kernel to version 4.11 or later.
Where can I find more information about CVE-2017-18257?
You can find more information about CVE-2017-18257 at the following references: [http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=b86e33075ed1909d8002745b56ecf73b833db143](http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=b86e33075ed1909d8002745b56ecf73b833db143), [https://github.com/torvalds/linux/commit/b86e33075ed1909d8002745b56ecf73b833db143](https://github.com/torvalds/linux/commit/b86e33075ed1909d8002745b56ecf73b833db143), [https://www.debian.org/security/2018/dsa-4188](https://www.debian.org/security/2018/dsa-4188).