CVE-2017-18264: phpMyAdmin Improper Privilege Management
An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20, 4.4.x, 4.6.x, and 4.7.0 prereleases. The restrictions caused by $cfg['Servers'][$i]['AllowNoPassword'] = false are bypassed under certain PHP versions (e.g., version 5). This can allow the login of users who have no password set even if the administrator has set $cfg['Servers'][$i]['AllowNoPassword'] to false (which is also the default). This occurs because some implementations of the PHP substr function return false when given '' as the first argument.
Other sources
phpMyAdmin Improper Privilege Management
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.7.0 - Upgrade
Upgrade
composer/phpmyadmin/phpmyadminto a version that resolves this vulnerability.Fixed in 4.0.10.20 - Upgrade
Upgrade
phpMyAdminto a version that resolves this vulnerability.Fixed in 4.0.10.20
Event History
Frequently Asked Questions
What is the vulnerability ID for this issue in phpMyAdmin?
The vulnerability ID for this issue in phpMyAdmin is CVE-2017-18264.
What is the severity of CVE-2017-18264?
The severity of CVE-2017-18264 is critical.
How does CVE-2017-18264 affect phpMyAdmin versions 4.0.x?
CVE-2017-18264 affects phpMyAdmin versions 4.0.x if they are before version 4.0.10.20.
How does CVE-2017-18264 affect phpMyAdmin versions 4.4.x?
CVE-2017-18264 affects phpMyAdmin versions 4.4.x if they are between version 4.4.0 and 4.4.15.10 (inclusive).
How does CVE-2017-18264 affect phpMyAdmin versions 4.6.x?
CVE-2017-18264 affects phpMyAdmin versions 4.6.x if they are between version 4.6.0 and 4.6.6 (inclusive).
How does CVE-2017-18264 affect phpMyAdmin version 4.7.0-beta1?
CVE-2017-18264 affects phpMyAdmin version 4.7.0-beta1.
How does CVE-2017-18264 affect phpMyAdmin version 4.7.0-rc1?
CVE-2017-18264 affects phpMyAdmin version 4.7.0-rc1.
How does CVE-2017-18264 affect Debian Debian Linux 8.0?
CVE-2017-18264 affects Debian Debian Linux 8.0.
Is there a fix available for CVE-2017-18264?
Yes, there is a fix available for CVE-2017-18264. Please refer to the references provided for more information.