7.8
Advisory Published
Updated

CVE-2017-18310

First published: Mon Aug 06 2018(Updated: )

ClientEnv exposes services 0-32 to HLOS in Snapdragon Automobile, Snapdragon Mobile, Snapdragon Wear in version MSM8909W, MSM8996AU, SD 210/SD 212/SD 205, SD 410/12, SD 425, SD 427, SD 430, SD 435, SD 450, SD 615/16/SD 415, SD 617, SD 625, SD 650/52, SD 810, SD 820, SD 820A, SD 835, SD 845, SDA660, SDM429, SDM439, SDM630, SDM632, SDM636, SDM660, Snapdragon_High_Med_2016

Credit: product-security@qualcomm.com

Affected SoftwareAffected VersionHow to fix
Google Android
Qualcomm Msm8909w Firmware
Qualcomm Msm8909w
Qualcomm Msm8996au Firmware
Qualcomm Msm8996au
Qualcomm Sd 210 Firmware
Qualcomm Sd 210
Qualcomm Sd 212 Firmware
Qualcomm Sd 212
Qualcomm Sd 205 Firmware
Qualcomm Sd 205
Qualcomm Sd 410 Firmware
Qualcomm Sd 410
Qualcomm Sd 412 Firmware
Qualcomm Sd 412
Qualcomm Sd 425 Firmware
Qualcomm Sd 425
Qualcomm Sd 427 Firmware
Qualcomm Sd 427
Qualcomm Sd 430 Firmware
Qualcomm Sd 430
Qualcomm Sd 435 Firmware
Qualcomm Sd 435
Qualcomm Sd 450 Firmware
Qualcomm Sd 450
Qualcomm Sd 615 Firmware
Qualcomm Sd 615
Qualcomm Sd 616 Firmware
Qualcomm Sd 616
Qualcomm Sd 415 Firmware
Qualcomm Sd 415
Qualcomm Sd 617 Firmware
Qualcomm Sd 617
Qualcomm Sd 625 Firmware
Qualcomm Sd 625
Qualcomm Sd 650 Firmware
Qualcomm Sd 650
Qualcomm Sd 652 Firmware
Qualcomm Sd 652
Google Android
Qualcomm Sd 810
Qualcomm Sd 820 Firmware
Qualcomm Sd 820
Qualcomm Sd 820a Firmware
Qualcomm Sd 820a
Qualcomm Sd 835 Firmware
Qualcomm Sd 835
Qualcomm Sd 845 Firmware
Qualcomm Sd 845
Qualcomm Sda660 Firmware
Qualcomm Sda660
Qualcomm Sdm429 Firmware
Qualcomm Sdm429
Qualcomm Sdm439 Firmware
Qualcomm Sdm439
Qualcomm Sdm630 Firmware
Qualcomm Sdm630
Qualcomm Sdm632 Firmware
Qualcomm Sdm632
Qualcomm Sdm636 Firmware
Qualcomm Sdm636
Qualcomm Sdm660 Firmware
Qualcomm Sdm660

Never miss a vulnerability like this again

Sign up to SecAlerts for real-time vulnerability data matched to your software, aggregated from hundreds of sources.

Frequently Asked Questions

  • What is CVE-2017-18310?

    CVE-2017-18310 is a vulnerability that allows the HLOS in Snapdragon devices to access services 0-32 in ClientEnv.

  • What is the severity of CVE-2017-18310?

    CVE-2017-18310 has a severity score of 7.8, which is considered critical.

  • Which products are affected by CVE-2017-18310?

    Google Android, Qualcomm MSM8909W, MSM8996AU, and Snapdragon Mobile and Wear are affected by CVE-2017-18310.

  • How can I fix CVE-2017-18310?

    To fix CVE-2017-18310, you should install the security patches provided by the vendor or update to the latest version of the affected software.

  • Where can I find more information about CVE-2017-18310?

    You can find more information about CVE-2017-18310 in the Android Security Bulletin for August 2018 or the Security Tracker website.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2024 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203