CVE-2017-18509: Input Validation

Published Aug 13, 2019
·
Updated

An issue was discovered in net/ipv6/ip6mr.c in the Linux kernel before 4.11. By setting a specific socket option, an attacker can control a pointer in kernel land and cause an inetcsklistenstop general protection fault, or potentially execute arbitrary code under certain circumstances. The issue can be triggered as root (e.g., inside a default LXC container or with the CAPNETADMIN capability) or after namespace unsharing. This occurs because sktype and protocol are not checked in the appropriate part of the ip6mroute functions. NOTE: this affects Linux distributions that use 4.9.x longterm kernels before 4.9.187.

Other sources

In ip6mroutesetsockopt and related functions of ip6mr.c, there is a possible out of bounds write due to a logic error in the code. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.

— OSV

Affected Software

11 affected componentsFixes available
Linux Linux kernel<3.16.72
Linux Linux kernel>=3.17<4.4.187
Linux Linux kernel>=4.5<4.9.187
Linux Linux kernel>=4.10<4.11
Canonical Ubuntu Linux=16.04
Debian Debian Linux=8.0
Debian Debian Linux=9.0
Debian Debian Linux=10.0
Google Android
android/:linux_kernel:>=:0<:2021-02-05
:2021-02-05
debian/linux
6.1.176-16.1.190-16.12.107-16.12.115-27.2.12-17.2.15-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade android/:linux_kernel: to a version that resolves this vulnerability.

    Fixed in :2021-02-05
  2. Upgrade

    Upgrade debian/linux to a version that resolves this vulnerability.

    Fixed in 6.1.176-1Fixed in 6.1.190-1Fixed in 6.12.107-1Fixed in 6.12.115-2Fixed in 7.2.12-1Fixed in 7.2.15-1

Event History

Aug 13, 2019
CVE Published
via Ubuntu·12:00 AM
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
CVE Published
via MITRE·01:17 PM
Data Sourced
via MITRE·01:17 PM
Description
Data Sourced
via NVD·02:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Feb 1, 2021
Advisory Published
via OSV·12:00 AM
Data Sourced
via Android·12:00 AM
SeverityWeaknessAffected Software
Data Sourced
via OSV·12:00 AM
DescriptionAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the vulnerability ID for this issue?

The vulnerability ID for this issue is CVE-2017-18509.

2

What is the severity level of CVE-2017-18509?

CVE-2017-18509 has a severity level of high.

3

Which software is affected by CVE-2017-18509?

CVE-2017-18509 affects various versions of the Linux kernel, including linux-gcp, linux-gcp-edge, linux-gke-4.15, linux, linux-aws, linux-aws-hwe, linux-azure, linux-azure-edge, linux-gke-5.0, linux-hwe, linux-hwe-edge, linux-kvm, linux-lts-trusty, linux-lts-xenial, linux-oem, linux-oracle, linux-raspi2, linux-snapdragon, and Google Android.

4

How can an attacker exploit CVE-2017-18509?

An attacker can exploit CVE-2017-18509 by setting a specific socket option, which allows them to control a pointer in the kernel and potentially execute arbitrary code.

5

Are there any patches or remedies available for CVE-2017-18509?

Yes, there are patches available to fix CVE-2017-18509. Please refer to the relevant sources for more information and updates.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203