CVE-2017-6924: REST API can bypass comment approval.

Published Aug 16, 2017
·
Updated

In Drupal 8 prior to 8.3.7; When using the REST API, users without the correct permission can post comments via REST that are approved even if the user does not have permission to post approved comments. This issue only affects sites that have the RESTful Web Services (rest) module enabled, the comment entity REST resource enabled, and where an attacker can access a user account on the site with permissions to post comments, or where anonymous users can post comments.

Affected Software

13 affected componentsFixes available
composer/drupal/core>=8.0, <8.1.0, >=8.1.0, <8.2.0, >=8.2.0, <8.3.0, >=8.3.0, <8.3.7
composer/drupal/drupal>=8.0, <8.1.0, >=8.1.0, <8.2.0, >=8.2.0, <8.3.0, >=8.3.0, <8.3.7
composer/drupal/drupal>=8.0<8.3.7
8.3.7
composer/drupal/core>=8.0<8.3.7
8.3.7
Drupal Drupal>=8.0.0<8.3.7
composer/drupal/core>=8.0, <8.1.0
composer/drupal/core>=8.1.0, <8.2.0
composer/drupal/core>=8.2.0, <8.3.0
composer/drupal/core>=8.3.0, <8.3.7
8.3.7
composer/drupal/drupal>=8.0, <8.1.0
composer/drupal/drupal>=8.1.0, <8.2.0
composer/drupal/drupal>=8.2.0, <8.3.0
composer/drupal/drupal>=8.3.0, <8.3.7
8.3.7

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/drupal/drupal to a version that resolves this vulnerability.

    Fixed in 8.3.7
  2. Upgrade

    Upgrade composer/drupal/core to a version that resolves this vulnerability.

    Fixed in 8.3.7
  3. Upgrade

    Upgrade Drupal 8 to a version that resolves this vulnerability.

    Fixed in 8.3.7

Event History

Aug 16, 2017
Advisory Published
05:10 PM
Data Sourced
via Packagist·05:10 PM
DescriptionSeverityAffected Software
Jan 15, 2019
CVE Published
via MITRE·08:00 PM
Data Sourced
via MITRE·08:00 PM
DescriptionWeakness

Frequently Asked Questions

1

What is the severity of CVE-2017-6924?

CVE-2017-6924 has been classified as a moderate severity vulnerability.

2

How do I fix CVE-2017-6924?

The vulnerability can be fixed by upgrading to Drupal version 8.3.7 or later.

3

Which versions of Drupal are affected by CVE-2017-6924?

CVE-2017-6924 affects Drupal versions prior to 8.3.7.

4

What specific component is vulnerable in CVE-2017-6924?

The vulnerability specifically affects the REST API in Drupal when the RESTful Web Services module is enabled.

5

Can unauthorized users exploit CVE-2017-6924?

Yes, users without the correct permissions can post approved comments via the REST API due to this vulnerability.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203