CVE-2017-7178: CSRF

Published Mar 18, 2017
·
Updated

CSRF was discovered in the web UI in Deluge before 1.3.14. The exploitation methodology involves (1) hosting a crafted plugin that executes an arbitrary program from its init.py file and (2) causing the victim to download, install, and enable this plugin.

Affected Software

4 affected componentsFixes available
Deluge-torrent Deluge<1.3.14
Debian Debian Linux=8.0
ubuntu/deluge*
debian/deluge
2.0.3-42.2.0-12.2.1~dev0+20260307-2

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/deluge to a version that resolves this vulnerability.

    Fixed in 2.0.3-4Fixed in 2.2.0-1Fixed in 2.2.1~dev0+20260307-2
  2. Upgrade

    Upgrade ubuntu/deluge to a version that resolves this vulnerability.

    Fixed in 1.3.12-1ubuntu1+esm1
  3. Upgrade

    Upgrade Deluge to a version that resolves this vulnerability.

    Fixed in 1.3.14

Event History

Mar 18, 2017
CVE Published
via Ubuntu·12:00 AM
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
CVE Published
via MITRE·08:10 PM
Data Sourced
via MITRE·08:10 PM
Description
Data Sourced
via NVD·08:59 PM
RemedyDescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·08:59 PM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2017-7178?

CVE-2017-7178 is considered a critical severity vulnerability due to its potential for arbitrary program execution via CSRF.

2

How do I fix CVE-2017-7178?

To fix CVE-2017-7178, upgrade Deluge to version 1.3.14 or later.

3

What type of vulnerability is CVE-2017-7178?

CVE-2017-7178 is a Cross-Site Request Forgery (CSRF) vulnerability.

4

Who is affected by CVE-2017-7178?

Users of Deluge versions prior to 1.3.14 and Debian GNU/Linux 8.0 are affected by CVE-2017-7178.

5

What does the exploitation of CVE-2017-7178 involve?

Exploitation of CVE-2017-7178 involves hosting a malicious plugin that executes arbitrary code when installed by the victim.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203