CVE-2017-7233: XSS

Published Mar 29, 2017
·
Updated

Django 1.10 before 1.10.7, 1.9 before 1.9.13, and 1.8 before 1.8.18 relies on user input in some cases to redirect the user to an "on success" URL. The security check for these redirects (namely django.utils.http.issafeurl()) considered some numeric URLs "safe" when they shouldn't be, aka an open redirect vulnerability. Also, if a developer relies on issafeurl() to provide safe redirect targets and puts such a URL into a link, they could suffer from an XSS attack.

Other sources

Django relies on user input in some cases (e.g. django.contrib.auth.views.login() and i18n to redirect the user to an "on success" URL. The security check for these redirects (namely django.utils.http.issafeurl()) considered some numeric URLs (e.g. http:999999999) "safe" when they shouldn't be.

Also, if a developer relies on issafeurl() to provide safe redirect targets and puts such a URL into a link, they could suffer from an XSS attack.

Affected versions: Django master development branch Django 1.11 (currently at release candidate status) Django 1.10 Django 1.9 Django 1.8

— Red Hat

Affected Software

79 affected componentsFixes available
pip/django>=1.8a1<1.8.18
1.8.18
pip/django>=1.9a1<1.9.13
1.9.13
pip/django>=1.10a1<1.10.7
1.10.7
djangoproject Django=1.8.0
djangoproject Django=1.8.0-a1
djangoproject Django=1.8.0-b1
djangoproject Django=1.8.0-b2
djangoproject Django=1.8.0-c1
djangoproject Django=1.8.1
djangoproject Django=1.8.2
djangoproject Django=1.8.3
djangoproject Django=1.8.4
djangoproject Django=1.8.5
djangoproject Django=1.8.6
djangoproject Django=1.8.7
djangoproject Django=1.8.8
djangoproject Django=1.8.9
djangoproject Django=1.8.10
djangoproject Django=1.8.11
djangoproject Django=1.8.12
djangoproject Django=1.8.13
djangoproject Django=1.8.14
djangoproject Django=1.8.15
djangoproject Django=1.8.16
djangoproject Django=1.8.17
djangoproject Django=1.9
djangoproject Django=1.9-a1
djangoproject Django=1.9-b1
djangoproject Django=1.9-rc1
djangoproject Django=1.9-rc2
djangoproject Django=1.9.1
djangoproject Django=1.9.2
djangoproject Django=1.9.3
djangoproject Django=1.9.4
djangoproject Django=1.9.5
djangoproject Django=1.9.6
djangoproject Django=1.9.7
djangoproject Django=1.9.8
djangoproject Django=1.9.9
djangoproject Django=1.9.10
djangoproject Django=1.9.11
djangoproject Django=1.9.12
djangoproject Django=1.10.0
djangoproject Django=1.10.0-a1
djangoproject Django=1.10.0-b1
djangoproject Django=1.10.0-rc1
djangoproject Django=1.10.1
djangoproject Django=1.10.2
djangoproject Django=1.10.3
djangoproject Django=1.10.4
djangoproject Django=1.10.5
djangoproject Django=1.10.6
redhat/python-django<1.8.18
1.8.18
redhat/python-django<1.9.13
1.9.13
redhat/python-django<1.10.7
1.10.7
redhat/python-django<1.11
1.11
alpine/py-django<1.10.7-r0
1.10.7-r0
alpine/py-django<1.8.18-r0
1.8.18-r0
alpine/py-django<1.8.18-r0
1.8.18-r0
alpine/py-django<1.8.18-r0
1.8.18-r0
alpine/py-django<1.8.18-r0
1.8.18-r0
alpine/py-django<1.10.7-r0
1.10.7-r0
alpine/py-django<1.10.7-r0
1.10.7-r0
alpine/py-django<1.10.7-r0
1.10.7-r0
alpine/py-django<1.10.7-r0
1.10.7-r0
alpine/py3-django<1.10.7-r0
1.10.7-r0
alpine/py3-django<1.10.7-r0
1.10.7-r0
alpine/py3-django<1.10.7-r0
1.10.7-r0
alpine/py3-django<1.10.7-r0
1.10.7-r0
alpine/py3-django<1.10.7-r0
1.10.7-r0
alpine/py3-django<1.10.7-r0
1.10.7-r0
alpine/py3-django<1.10.7-r0
1.10.7-r0
alpine/py3-django<1.10.7-r0
1.10.7-r0
alpine/py3-django<1.10.7-r0
1.10.7-r0
alpine/py3-django<1.10.7-r0
1.10.7-r0
alpine/py3-django<1.10.7-r0
1.10.7-r0
alpine/py3-django<1.10.7-r0
1.10.7-r0
alpine/py3-django<1.10.7-r0
1.10.7-r0
alpine/py3-django<1.10.7-r0
1.10.7-r0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade pip/Django to a version that resolves this vulnerability.

    Fixed in 1.8.18
  2. Upgrade

    Upgrade pip/Django to a version that resolves this vulnerability.

    Fixed in 1.9.13
  3. Upgrade

    Upgrade pip/Django to a version that resolves this vulnerability.

    Fixed in 1.10.7
  4. Upgrade

    Upgrade redhat/python-django to a version that resolves this vulnerability.

    Fixed in 1.8.18
  5. Upgrade

    Upgrade redhat/python-django to a version that resolves this vulnerability.

    Fixed in 1.9.13
  6. Upgrade

    Upgrade redhat/python-django to a version that resolves this vulnerability.

    Fixed in 1.10.7
  7. Upgrade

    Upgrade redhat/python-django to a version that resolves this vulnerability.

    Fixed in 1.11
  8. Upgrade

    Upgrade alpine/py-django to a version that resolves this vulnerability.

    Fixed in 1.10.7-r0
  9. Upgrade

    Upgrade alpine/py-django to a version that resolves this vulnerability.

    Fixed in 1.8.18-r0
  10. Upgrade

    Upgrade alpine/py3-django to a version that resolves this vulnerability.

    Fixed in 1.10.7-r0
  11. Upgrade

    Upgrade django/django to a version that resolves this vulnerability.

    Fixed in 1.10.7
  12. Upgrade

    Upgrade django/django to a version that resolves this vulnerability.

    Fixed in 1.9.13
  13. Upgrade

    Upgrade django/django to a version that resolves this vulnerability.

    Fixed in 1.8.18

Event History

Mar 29, 2017
Data Sourced
via Red Hat·08:36 PM
DescriptionSeverityAffected Software
Apr 4, 2017
CVE Published
via MITRE·05:00 PM
Data Sourced
via MITRE·05:00 PM
Description
Data Sourced
via NVD·05:59 PM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·05:59 PM
DescriptionSeverityAffected Software
Jan 4, 2019
Advisory Published
via GitHub·05:50 PM

Frequently Asked Questions

1

What is the severity of CVE-2017-7233?

CVE-2017-7233 is classified as a medium severity vulnerability.

2

How do I fix CVE-2017-7233?

To fix CVE-2017-7233, upgrade Django to version 1.10.7, 1.9.13, or 1.8.18 or later.

3

What versions of Django are affected by CVE-2017-7233?

CVE-2017-7233 affects Django versions 1.10 before 1.10.7, 1.9 before 1.9.13, and 1.8 before 1.8.18.

4

What type of vulnerability is CVE-2017-7233?

CVE-2017-7233 is a security vulnerability related to improper URL validation.

5

Is user input involved in the exploitation of CVE-2017-7233?

Yes, CVE-2017-7233 relies on user input in some cases, leading to potential security risks.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203