CVE-2017-7375: XEE
A flaw in libxml2 allows remote XML entity inclusion with default parser flags (i.e., when the caller did not request entity substitution, DTD validation, external DTD subset loading, or default DTD attributes). Depending on the context, this may expose a higher-risk attack surface in libxml2 not usually reachable with default parser flags, and expose content from local files, HTTP, or FTP servers (which might be otherwise unreachable).
Other sources
Missing validation for external entities was found in xmlParsePEReference that can lead to XXE attack.
Upstream bug (private at the moment):
https://bugzilla.gnome.org/showbug.cgi?id=780691
Android patch:
https://android.googlesource.com/platform/external/libxml2/+/308396a55280f69ad4112d4f9892f4cbeff042aa
References:
https://source.android.com/security/bulletin/2017-06-01#libraries
— Red Hat
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/libxml2to a version that resolves this vulnerability.Fixed in 2.9.4+dfsg1-7+deb10u4Fixed in 2.9.4+dfsg1-7+deb10u6Fixed in 2.9.10+dfsg-6.7+deb11u4Fixed in 2.9.14+dfsg-1.3~deb12u1Fixed in 2.9.14+dfsg-1.3 - Upgrade
Upgrade
debian/libxml2to a version that resolves this vulnerability.Fixed in 2.9.4+dfsg1-3.1Fixed in 2.9.4+dfsg1-2.2+deb9u1Fixed in 2.9.1+dfsg1-5+deb8u5 - Upgrade
Upgrade
redhat/libxml2to a version that resolves this vulnerability.Fixed in 2.9.5 - Upgrade
Upgrade
libxml2to a version that resolves this vulnerability.Patch 308396a55280f69ad4112d4f9892f4cbeff042aa
Event History
Frequently Asked Questions
What is the severity of CVE-2017-7375?
CVE-2017-7375 is considered a moderate severity vulnerability due to its potential for remote exploitation.
How do I fix CVE-2017-7375?
To fix CVE-2017-7375, update libxml2 to versions 2.9.4+dfsg1-7+deb10u4 or higher for Debian systems, and 2.9.5 or higher for Red Hat systems.
Which software is affected by CVE-2017-7375?
CVE-2017-7375 affects multiple versions of libxml2 across Debian and Google Android platforms.
Can CVE-2017-7375 lead to data exposure?
Yes, CVE-2017-7375 can potentially lead to exposure of sensitive data through XML entity inclusion.
Is CVE-2017-7375 in a supported version of libxml2?
Versions of libxml2 prior to 2.9.4+dfsg1-7 and 2.9.5 are vulnerable to CVE-2017-7375 and should be updated.