CVE-2017-7544: Critical severity Libexif Project Libexif vulnerability
Last updated 25 August 2025
Other sources
libexif through 0.6.21 is vulnerable to out-of-bounds heap read vulnerability in exifdatasavedataentry function in libexif/exif-data.c caused by improper length computation of the allocated data of an ExifMnote entry which can cause denial-of-service or possibly information disclosure.
— Launchpad
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/libexifto a version that resolves this vulnerability.Fixed in 0.6.21-r3 - Upgrade
Upgrade
alpine/libexifto a version that resolves this vulnerability.Fixed in 0.6.21-r2 - Upgrade
Upgrade
debian/libexifto a version that resolves this vulnerability.Fixed in 0.6.24-1+deb12u1Fixed in 0.6.25-1+deb13u1Fixed in 0.6.26-1
Event History
Frequently Asked Questions
What is the vulnerability ID for this vulnerability?
The vulnerability ID is CVE-2017-7544.
What is the severity of CVE-2017-7544?
The severity of CVE-2017-7544 is critical with a severity value of 9.1.
Which software versions are affected by CVE-2017-7544?
Versions up to and including libexif 0.6.21 are affected by CVE-2017-7544.
What is the impact of CVE-2017-7544?
CVE-2017-7544 can cause denial-of-service or possibly information disclosure.
Are there any fixes or patches available for CVE-2017-7544?
Yes, fixes or patches are available for CVE-2017-7544. Please refer to the references for more information.