CVE-2017-7702: High severity Wireshark Wireshark vulnerability
In Wireshark 2.2.0 to 2.2.5 and 2.0.0 to 2.0.11, the WBXML dissector could go into an infinite loop, triggered by packet injection or a malformed capture file. This was addressed in epan/dissectors/packet-wbxml.c by adding length validation.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.6-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2017-7702?
CVE-2017-7702 has a medium severity rating due to its potential to cause a denial of service in Wireshark.
How do I fix CVE-2017-7702?
To fix CVE-2017-7702, upgrade to Wireshark versions 2.2.6 or later, or 2.0.12 or later.
What types of Wireshark versions are affected by CVE-2017-7702?
CVE-2017-7702 affects Wireshark versions from 2.0.0 to 2.0.11 and 2.2.0 to 2.2.5.
What kind of attack does CVE-2017-7702 facilitate?
CVE-2017-7702 facilitates a denial of service attack via crafted WBXML packets.
What component of Wireshark does CVE-2017-7702 affect?
CVE-2017-7702 affects the WBXML dissector component in Wireshark.