CVE-2017-7703: High severity Wireshark Wireshark vulnerability
In Wireshark 2.2.0 to 2.2.5 and 2.0.0 to 2.0.11, the IMAP dissector could crash, triggered by packet injection or a malformed capture file. This was addressed in epan/dissectors/packet-imap.c by calculating a line's end correctly.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.6-r0
Event History
Frequently Asked Questions
What versions of Wireshark are affected by CVE-2017-7703?
Wireshark versions 2.0.0 to 2.0.11 and 2.2.0 to 2.2.5 are affected by CVE-2017-7703.
What is the impact of CVE-2017-7703 on Wireshark?
CVE-2017-7703 can cause the IMAP dissector to crash when triggered by packet injection or a malformed capture file.
How can I fix CVE-2017-7703 in Wireshark?
To fix CVE-2017-7703, update Wireshark to a version later than 2.2.5 or 2.0.11.
Has CVE-2017-7703 been addressed in any security updates?
Yes, CVE-2017-7703 has been addressed in later versions of Wireshark through a fix in the IMAP dissector.
Is CVE-2017-7703 related to any other vulnerabilities in Wireshark?
CVE-2017-7703 is specific to the IMAP dissector; however, similar issues can arise with other dissectors if not properly handled.