CVE-2017-8346: Medium severity imagemagick vulnerability

Published Apr 30, 2017
·
Updated

In ImageMagick 7.0.5-5, the ReadDCMImage function in dcm.c allows attackers to cause a denial of service (memory leak) via a crafted file.

Affected Software

3 affected components
ImageMagick ImageMagick=7.0.5-5
Debian Debian Linux=8.0
Debian Debian Linux=9.0

Event History

Apr 30, 2017
CVE Published
via MITRE·05:00 PM
Data Sourced
via MITRE·05:00 PM
Description

Frequently Asked Questions

1

What is the severity of CVE-2017-8346?

CVE-2017-8346 has a severity rating that indicates it can lead to a denial of service due to a memory leak.

2

How do I fix CVE-2017-8346?

To fix CVE-2017-8346, update ImageMagick to a version later than 7.0.5-5 that addresses this vulnerability.

3

Which versions of ImageMagick are affected by CVE-2017-8346?

CVE-2017-8346 affects ImageMagick version 7.0.5-5.

4

Does CVE-2017-8346 affect Debian systems?

Yes, CVE-2017-8346 affects Debian systems running version 8.0 and 9.0 that utilize ImageMagick 7.0.5-5.

5

What type of attack is possible with CVE-2017-8346?

CVE-2017-8346 allows attackers to perform a denial of service attack by causing a memory leak via a crafted file.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203