CVE-2017-8809: Critical severity MediaWiki MediaWiki vulnerability
api.php in MediaWiki before 1.27.4, 1.28.x before 1.28.3, and 1.29.x before 1.29.2 has a Reflected File Download vulnerability.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/mediawikito a version that resolves this vulnerability.Fixed in 1:1.31.16-1+deb10u2Fixed in 1:1.31.16-1+deb10u6Fixed in 1:1.35.11-1~deb11u1Fixed in 1:1.35.13-1~deb11u1Fixed in 1:1.39.4-1~deb12u1Fixed in 1:1.39.5-1~deb12u1Fixed in 1:1.39.5-1
Event History
Frequently Asked Questions
What is the severity of CVE-2017-8809?
CVE-2017-8809 has a medium severity rating due to its Reflected File Download vulnerability.
How do I fix CVE-2017-8809?
To resolve CVE-2017-8809, update MediaWiki to version 1.27.4, 1.28.3, or 1.29.2 or later.
Which MediaWiki versions are affected by CVE-2017-8809?
CVE-2017-8809 affects MediaWiki versions up to 1.27.3 and specific versions including 1.28.0, 1.28.1, 1.28.2, 1.29.0, and 1.29.1.
Is CVE-2017-8809 still a risk for users of MediaWiki?
Yes, users of the affected MediaWiki versions remain at risk for CVE-2017-8809 if they have not upgraded.
What type of vulnerability is CVE-2017-8809?
CVE-2017-8809 is a Reflected File Download vulnerability that could potentially allow attackers to download arbitrary files.