CVE-2017-9031: Path Traversal
The WebUI component in Deluge before 1.3.15 contains a directory traversal vulnerability involving a request in which the name of the render file is not associated with any template file.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/delugeto a version that resolves this vulnerability.Fixed in 2.0.3-4Fixed in 2.2.0-1Fixed in 2.2.1~dev0+20260307-2 - Upgrade
Upgrade
ubuntu/delugeto a version that resolves this vulnerability.Fixed in 1.3.12-1ubuntu1+esm1
Event History
Frequently Asked Questions
What is the severity of CVE-2017-9031?
CVE-2017-9031 has been reported as a medium severity vulnerability due to its potential for directory traversal.
How do I fix CVE-2017-9031?
To fix CVE-2017-9031, upgrade Deluge to version 1.3.15 or later.
What impact does CVE-2017-9031 have on my system?
CVE-2017-9031 allows an attacker to potentially access sensitive files outside the intended directories.
Which versions of Deluge are affected by CVE-2017-9031?
Deluge versions prior to 1.3.15 are affected by CVE-2017-9031.
Is CVE-2017-9031 exploited in the wild?
There are no public reports indicating that CVE-2017-9031 is currently being exploited in the wild.