CVE-2017-9346: High severity Wireshark Wireshark vulnerability
In Wireshark 2.2.0 to 2.2.6 and 2.0.0 to 2.0.12, the SoulSeek dissector could go into an infinite loop. This was addressed in epan/dissectors/packet-slsk.c by making loop bounds more explicit.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.7-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2017-9346?
CVE-2017-9346 is categorized as a medium severity vulnerability due to the potential for denial of service through an infinite loop.
How do I fix CVE-2017-9346?
To fix CVE-2017-9346, upgrade Wireshark to versions 2.2.7 or later and 2.0.13 or later.
What versions of Wireshark are affected by CVE-2017-9346?
CVE-2017-9346 affects Wireshark versions from 2.0.0 to 2.0.12 and 2.2.0 to 2.2.6.
What component of Wireshark does CVE-2017-9346 involve?
CVE-2017-9346 involves the SoulSeek dissector in Wireshark.
What can happen if I don't address CVE-2017-9346?
If not addressed, CVE-2017-9346 can lead to a denial of service by causing the application to become unresponsive.