CVE-2017-9351: Buffer Overflow
In Wireshark 2.2.0 to 2.2.6 and 2.0.0 to 2.0.12, the DHCP dissector could read past the end of a buffer. This was addressed in epan/dissectors/packet-bootp.c by extracting the Vendor Class Identifier more carefully.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.7-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2017-9351?
CVE-2017-9351 is classified as a medium severity vulnerability.
How do I fix CVE-2017-9351?
To fix CVE-2017-9351, upgrade Wireshark to version 2.2.7 or later if you are using the 2.2.x series, or to version 2.0.13 or later if you are using the 2.0.x series.
Which versions of Wireshark are affected by CVE-2017-9351?
Wireshark versions from 2.0.0 to 2.0.12 and from 2.2.0 to 2.2.6 are affected by CVE-2017-9351.
What type of vulnerability is CVE-2017-9351?
CVE-2017-9351 is a buffer overflow vulnerability in the DHCP dissector of Wireshark.
Who is impacted by CVE-2017-9351?
Users of affected versions of Wireshark who analyze DHCP packets could be impacted by CVE-2017-9351.