CVE-2017-9352: High severity Wireshark Wireshark vulnerability
In Wireshark 2.2.0 to 2.2.6 and 2.0.0 to 2.0.12, the Bazaar dissector could go into an infinite loop. This was addressed in epan/dissectors/packet-bzr.c by ensuring that backwards parsing cannot occur.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.7-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2017-9352?
CVE-2017-9352 has been classified as a medium severity vulnerability.
How do I fix CVE-2017-9352?
To fix CVE-2017-9352, upgrade Wireshark to version 2.2.7 or later, or 2.0.13 or later.
What versions of Wireshark are affected by CVE-2017-9352?
CVE-2017-9352 affects Wireshark versions 2.0.0 to 2.0.12 and 2.2.0 to 2.2.6.
What is the impact of CVE-2017-9352?
The vulnerability can cause Wireshark to enter an infinite loop, potentially leading to a denial of service.
Who discovered CVE-2017-9352?
CVE-2017-9352 was reported by security researchers analyzing the Bazaar dissector in Wireshark.