CVE-2017-9354: Input Validation
In Wireshark 2.2.0 to 2.2.6 and 2.0.0 to 2.0.12, the RGMP dissector could crash. This was addressed in epan/dissectors/packet-rgmp.c by validating an IPv4 address.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/wiresharkto a version that resolves this vulnerability.Fixed in 2.2.7-r0
Event History
Frequently Asked Questions
What is the severity of CVE-2017-9354?
CVE-2017-9354 is categorized as a moderate severity vulnerability that can lead to application crashes.
How do I fix CVE-2017-9354?
To fix CVE-2017-9354, upgrade to Wireshark version 2.2.7 or 2.0.13 or later.
What are the affected versions of Wireshark for CVE-2017-9354?
Wireshark versions 2.0.0 through 2.0.12 and 2.2.0 through 2.2.6 are affected by CVE-2017-9354.
What type of attack does CVE-2017-9354 enable?
CVE-2017-9354 can enable denial of service attacks due to application crashes caused by the RGMP dissector.
What component of Wireshark does CVE-2017-9354 affect?
CVE-2017-9354 specifically affects the RGMP dissector in Wireshark.